WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Trouble to make WPSC to work on managed VPS (3 posts)

  1. Francisco Aguirre
    Member
    Posted 2 years ago #

    Hi,

    I have a VPS and, having two sites using the same WP version (3.3), the same framework (genesis), the same WPSC version (1.0) on the same server (Servint), one runs the plugin without problems and the other just can't create html files, nor file's codeview show the "<!-- Dynamic page generated in 0.628 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2011-12-11 19:52:36 -->" legend.

    Even the tech team at Servint are being unable so far to make it work and so I come to ask for help. I have enabled debug mode and this is what I get:

    06:31:43 /wp-admin/options-general.php?page=wpsupercache&tab=debug scheduled wp_cache_check_site_hook for 360 seconds time.
    06:31:48 /url.html?replytocom=202 No wp-cache file served as user agent rejected.
    06:31:48 /url.html?replytocom=202 In WP Cache Phase 2
    06:31:48 /url.html?replytocom=202 Setting up WordPress actions
    06:31:48 /url.html?replytocom=202 Supercache caching disabled. Only using wp-cache. Non empty GET request.
    06:31:48 /url.html?replytocom=202 USER AGENT (Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)) rejected. Not Caching
    06:32:11 /url1.html/comment-page-1/?replytocom=2433 No wp-cache file served as user agent rejected.
    06:32:11 /url1.html/comment-page-1/?replytocom=2433 In WP Cache Phase 2
    06:32:11 /url1.html/comment-page-1/?replytocom=2433 Setting up WordPress actions
    06:32:11 /url1.html/comment-page-1/?replytocom=2433 Supercache caching disabled. Only using wp-cache. Non empty GET request.
    06:32:11 /url1.html/comment-page-1/?replytocom=2433 USER AGENT (Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)) rejected. Not Caching
    06:32:16 /directory/ supercache dir: /home/vinco01/public_html/wp-content/cache/supercache/site.org/noticias/
    06:32:16 /noticias/ No wp-cache file exists. Must generate a new one.
    06:32:16 /noticias/ In WP Cache Phase 2
    06:32:16 /noticias/ Setting up WordPress actions
    06:32:16 /noticias/ Created output buffer
    06:32:17 /noticias/ DONOTCACHEPAGE defined. Caching disabled.
    06:32:22 / supercache dir: /home/vinco01/public_html/wp-content/cache/supercache/site.org/
    06:32:22 / No wp-cache file exists. Must generate a new one.
    06:32:22 / In WP Cache Phase 2
    06:32:22 / Setting up WordPress actions
    06:32:22 / Created output buffer
    06:32:23 / DONOTCACHEPAGE defined. Caching disabled.
    06:32:27 /url2.html supercache dir: /home/vinco01/public_html/wp-content/cache/supercache/site.org/url2.html/
    06:32:27 /url2.html No wp-cache file exists. Must generate a new one.
    06:32:27 /url2.html In WP Cache Phase 2
    06:32:27 /url2.html Setting up WordPress actions
    06:32:27 /url2.html Created output buffer
    06:32:27 /url3/ No wp-cache file served as user agent rejected.
    06:32:28 /url3/ In WP Cache Phase 2
    06:32:28 /url3/ Setting up WordPress actions
    06:32:28 /url3/ USER AGENT (Mozilla/5.0 (compatible; AhrefsBot/2.0; +http://ahrefs.com/robot/)) rejected. Not Caching
    06:32:28 /url2.html DONOTCACHEPAGE defined. Caching disabled.
    06:32:34 /url4.html supercache dir: /home/vinco01/public_html/wp-content/cache/supercache/site.org/url4.html/
    06:32:34 /url4.html No wp-cache file exists. Must generate a new one.
    06:32:34 /url4.html In WP Cache Phase 2
    06:32:34 /url4.html Setting up WordPress actions
    06:32:34 /url4.html Created output buffer
    06:32:35 /url4.html DONOTCACHEPAGE defined. Caching disabled.

    I'm not tech savvy, but despite this last line of code, cache is enabled and all tests were made from a loggedout browser. What may be happening?

    All help will be greatly appreciated.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    The constant DONOTCACHEPAGE is defined somewhere on your site and that disables caching. Some other plugin or theme probably set it. Find that and you've found the problem!

  3. Francisco Aguirre
    Member
    Posted 2 years ago #

    Thanks a lot Donncha,

    As you said that was exactly the problem, and so I managed to resolve it by simply changing this:

    define('DONOTCACHEPAGE', true);

    into this:

    define('DONOTCACHEPAGE');

    Now pages are being cached normally. Thank you again for taking the time to help me, and have a nice day :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic