WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] Supercache folder only contains empty subdirectories (23 posts)

  1. arminbw
    Member
    Posted 5 years ago #

    I installed Supercache 0.6.7 on WordPress 2.5.1. While cashed pages getting served now and data clutters up the wp-cache and meta directories, the supercache directory only contains empty subdirectories, but no files.

    The troubleshooting section of the readme file states the following:

    7. Look in wp-content/cache/supercache/. Are there directories and files there?

    Unfortunately it doesn't provide any hints how this issue can be solved.

    Thank's for any advice,
    Armin

  2. indiabolbol
    Member
    Posted 5 years ago #

    Yes, I am getting the same issue. WP-cache is caching pages but WP-Super cache is not caching any pages. It just creates empty directory with name of the post's permalink. This is happening after the latest update.

    Any suggestions? help?
    I am using wp 2.6.1 with Wp-supercache 0.7.1 with eaccelerator.

  3. arminbw
    Member
    Posted 5 years ago #

    After the upgrade (0.7.1) the source code of my pages still look like this:

    <!-- Dynamic Page Served (once) in 0.996 seconds -->
    <!-- Cached page served by WP-Cache -->

    While the default cache is working, supercache only creates empty directories. Php safe_mode is off. Compression is turned off. No special plugins are installed.

    Is there some error-log function I can activate? Unfortunately I cannot access the php error_log.

  4. arminbw
    Member
    Posted 5 years ago #

    Anyway, uninstalled it.

  5. microguy
    Member
    Posted 5 years ago #

    Same problem. I'm getting ready to uninstall it too. I tried to rate it one star but the WordPress rating script is broken too. :o(

  6. cosmictap
    Member
    Posted 5 years ago #

    Same issue here. When I try to create a "directly cached file" all I get is a blank subdirectory served up.

    ideas? looks like no.

  7. stevemagruder
    Member
    Posted 5 years ago #

    Resolved? I'm still seeing this problem with the latest release.

  8. aaurel1an
    Member
    Posted 5 years ago #

    Same here... only empty directories...

  9. ljmacphee
    Member
    Posted 5 years ago #

    Me too, installed it across a dozen websites last night and not a single cache file exists.

  10. pengrus
    Member
    Posted 5 years ago #

    I am getting the same problem with the latest version 0.85. The supercache only has empty directories, with no files.

  11. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Do you have safe_mode on? What does ini_get( 'safe_mode' ); return? It should return false, but may return the string 'Off' for some reason.

    I need more details about your webserver - Apache, PHP, modules loaded, configuration? Any security checks?

  12. Djay77
    Member
    Posted 5 years ago #

    I am in the same case,
    My safe_mode in php.ini is set to Off
    (Off is the normal configuration for safe_mode)

    And my directory in supercache/ are empty too

  13. stevemagruder
    Member
    Posted 5 years ago #

    In my case, safe_mode is Off.

    PHP version: 5.2.6
    Apache version: 2.2.8

    Configure command: Command './configure' '--enable-bcmath' '--enable-calendar' '--enable-exif' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-zip' '--prefix=/usr' '--with-bz2' '--with-curl=/opt/curlssl/' '--with-curlwrappers' '--with-freetype-dir=/usr' '--with-gd' '--with-gettext' '--with-jpeg-dir=/usr' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mhash=/opt/mhash/' '--with-mime-magic' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-pspell' '--with-sqlite=shared' '--with-ttf' '--with-xpm-dir=/usr' '--with-xsl=/opt/xslt/' '--with-zlib' '--with-zlib-dir=/usr'

    I'll be happy to supply any more info asked for.

  14. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Interesting, PHP5, anyone else on this thread using PHP5? Are you using Fastcgi?

  15. Djay77
    Member
    Posted 5 years ago #

    I use PHP 5 too and eAccelerator
    Apache/2.2.8 (Ubuntu) PHP/5.2.4-2ubuntu5.3 with Suhosin-Patch

  16. Donncha O Caoimh
    Member
    Posted 5 years ago #

    What ftp clients are you using when checking the supercache directory? Just out of curiosity, can you try another one?

    Djay77 - any chance you could give me login details to your hosting account so I can try to figure this out? I checked a dreamhost account this afternoon and the supercache folders did have index.html files. It started working somehow before I got a chance to debug it!

  17. Djay77
    Member
    Posted 5 years ago #

    I tried with WINSCP, same in SSH with root access.

    Folders are correctly created in supercache (exemple: forums.bloogx.com/2008/12/02/my-post) but without any .html cache

    In wp-content/cache I have all html statics caches like wp-cache-forums.bloogx.com360a8ecd5c6d1f1327fd24d53efc7f61.html

    Sorry but I can't give you access to my server, there are too many projects and differents users who used him.
    Tell me if you need more details about the configuration.

    My MSN if needed : didje(AT)9634.net

    Thanks

  18. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Are you using suexec? I've tried PHP5+fast cgi+apache2 and it works fine.

  19. Donncha O Caoimh
    Member
    Posted 5 years ago #

    What version of PHP5 are you all using? If it's 5.2.4 that could be the problem.

  20. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Never mind, upgrade to 0.8.6 and it should work again. Ironically, going through the Troubleshooting section of the readme.txt would have fixed this I think.. See this thread for more details.

  21. DaveSanClemente
    Member
    Posted 5 years ago #

    I was having the same problem - supercache directory was empty - no cached files.

    Then, I read somewhere that you'll only see normal cache files when logged in or if you left a comment. So, I logged out (I was using Firefox). Still only normal cache pages.

    But, then I tried going to my site through my iphone browser. Viola! I started getting supercache files generated and served. Also, I opened a different browser (Safari), went to my site and got super cache pages.

    So empty supercache directories when logged in is a feature! lol.

    Donncha, you wrote awesome plug-in. My site is blazing fast. Thanks.

  22. derixc
    Member
    Posted 5 years ago #

    directly cache files is not working for me. I hae APC installed on my server (mt dv base) and I don't know if it is something to do with it.

    This is what I am getting after I direct cached the files

    http://yuwoncedric.com/exhausting

  23. samxnguyen
    Member
    Posted 5 years ago #

    I was having the same problem. In the Super Cache settings page, I would see the WP-Cache counter increasing but WP-Super-Cache would stay at zero.

    The readme.txt states that static pages will be served to:

    Users who have not left a comment on your blog.

    So in Firefox I cleared my private data to prevent sending any old cookies, and Super-Cache started counting up!

    So if you are having this problem, try clearing your cookies or using a different browser.

Topic Closed

This topic has been closed to new replies.

About this Topic