WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Supercache almost(?) working? (7 posts)

  1. blakekr
    Member
    Posted 5 years ago #

    Using: SP 0.7.1

    Thanks for your patience in advance. I need to get this working so am asking a lot of questions!

    I'm running this with gz compression. I have WP_CACHE and OBJECT_CACHE enabled in wp-config. Supercache is definitely creating files in /cache, /cache/meta and /cache/supercache under wp-content. It creates a whole tree mirroring the site under supercache, and right now reports that there are 3 cached pages in wp-cache and 56 pages in wp-super-cache.

    The problem is that I can't seem to catch it serving a cached page. If I go from a recognized browser, I see this type of thing at the bottom:
    -------------------------------------------------------------
    <!-- Dynamic Page Served (once) in 2.044 seconds -->

    If I go from an anonymous browser, I see this:
    -------------------------------------------------------------

    <!-- Dynamic Page Served (once) in 2.044 seconds -->
    <!-- super cache gz -->

    It seems hopeful because the anon browser returns that supercache gz signature, but I think I should be getting a Served from Cache message instead, right?

  2. Rishi
    Member
    Posted 5 years ago #

    Did you try
    1.) Clearing your expired and cached pages from Settings-->WP Super Cache
    2.) Clearing your browser cookies and cache content
    3.) Logging back into WordPress and reaccessing your pages while you're logged in

    I don't use GZip, but these are my messages:

    For logged users like me:

    <!-- Dynamic Page Served (once) in 1.301 seconds -->
    <!-- Cached page served by WP-Cache -->

    For non-logged users:

    <!-- Dynamic Page Served (once) in 1.161 seconds -->
    <!-- super cache -->

    The signature you're getting for anonymous visits is correct, from what I believe to be the case with GZip users. You *are* serving cached pages. I think you're set. =)

    http://www.rishi-kumar.com

  3. blakekr
    Member
    Posted 5 years ago #

    Hey, thanks for your reply. I ended up taking off gzip because my server was having big problems with all that executable activity, but now pages seem to serve up fast, especially as anon. Thanks for the confirmation that things are working! :)

  4. michaelpark
    Member
    Posted 5 years ago #

    I'm not getting...

    <!-- super cache gz -->

    ...even when I'm logged out.

    What could be wrong?

    michaelpark.net

  5. Rishi
    Member
    Posted 5 years ago #

    blakekr - Glad I could help! Yeah, GZip seems to be a big hassle with my shared host (Dot5Hosting).

    Michael - what *are* you getting? (For both logged in users and anonymous visitors). Make sure you clear your cookies and cache before testing.

  6. michaelpark
    Member
    Posted 5 years ago #

    Never mind, I think it's working.

  7. blakekr
    Member
    Posted 5 years ago #

    All right, I am not trying to be a pain in the butt, but what things would cause Super Cache to stop caching pages? I find that something will sometimes cause it to cache three or so pages, and then freeze at that amount until I do something like clear the cache. I am not sure if it's moderating comments that causes this "freeze" or something else. Anyone have any guesses?

Topic Closed

This topic has been closed to new replies.

About this Topic