WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] Supercache : 301 not working with ?p= in IE only WP2.6 (3 posts)

  1. TheWebHead
    Member
    Posted 5 years ago #

    I tried installing this yesterday only to observe that my server load didn't drop - because IE users, perhaps the crawlers too, were not redirecting to my custom permalink /%postname%/%post_id%/, but instead were going to the homepage (and loading 10 stories) and returning a 200 code. The firefox setup did properly redirect users.

    So now I'm only running WP Cache and removed that offending code, and everything works again. I'd like to enable supercache, but I need the ?p= pages to properly redirect, especially since I just changed platforms to wordpress, so all the SEs are pointing to old URLs.

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Try adding the following line to each of the mod_rewrite chunks in your .htaccess

    RewriteCond %{QUERY_STRING} !.*p=.*

    That should stop mod_rewrite serving static files for the ?p= urls and the redirect can happen then. Does that work?

  3. TheWebHead
    Member
    Posted 5 years ago #

    Cool. I added that line below the two !=POST lines and it now works in both IE and Firefox. I think you may want to update based on this minor edit, since many don't go and check if their redirects work often and especially if it only occurs in IE. All those pages returning a 200 code at the homepage can result in duplicate content issues as well.

Topic Closed

This topic has been closed to new replies.

About this Topic