WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Super Cache doesn't cache properly (2 posts)

  1. vici
    Member
    Posted 4 years ago #

    I've been having truly weird wp super cache problems. I mean I used to have it installed on my server but then I got rid of it for a while.
    After receiving lots of messages from my server saying it's out of memory, I decided to re-install wp super cache again but in my opinion it doesn't work properly.
    I installed it like a week ago and now there are only 6 pages cached and 1 super cached (my website has like 500 pages!). Moreover it looks like it's only caching files from feed (http://domain.com/article/feed) and it super cached only a main page. I assume it can be related to the directive of not caching index\.php files because I checked the google webmaster's tools and it showed me lots of pages indexed but all of them were like duplicate. I mean http://domain.com/article/ and http://domain.com/article/index.php were both listed there which is as far as SEO incorrect
    so has wp super cache messed up my htaccess settings? not only it's not caching but also making my website full of duplicate content, how can I fix it?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Posted 4 years ago #

    WordPress should automatically redirect index.php to / and Supercache won't cache them. Not sure why that doesn't work for you.

    You should probably use the debug system in the plugin to figure out what it's caching.

Topic Closed

This topic has been closed to new replies.

About this Topic