WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Suggestion for uninstall instructions (12 posts)

  1. hussong
    Member
    Posted 3 years ago #

    After being bitten by this on two sites in the past few days, I'd suggest adding the following to the uninstall instructions (other notes):

    - Flush your permalink cache.

    When you remove the .htaccess rules generated by WP Super Cache, all permalinks may stop working. Except for the home page (which makes it really easy to miss at first sight). Changing the permalink settings to something else and back to your previous setting (hit save each time) solves the problem instantly.

    Hope this helps, and thanks for this awesome plugin!

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    hussong - you probably removed the WordPress rules as well as the Supercache ones. I'll add a troubleshooting note to set the permalink again if problems occur, that's a good idea.

  3. hussong
    Member
    Posted 3 years ago #

    I'm pretty sure I removed the Supercache rules only (I remember double checking when I edited the files). Anyway, thanks for adding the troubleshooting note!

  4. bob_wp
    Member
    Posted 3 years ago #

    Hi

    If you are set to the default settings under 3.0, there are no rules installed in .htaccess. If the switch is re-writing rules, I suspect it's only going to work if you switch between the "right" two things.

    Crazy stuff ...

    Bob

  5. hussong
    Member
    Posted 3 years ago #

    I had it set to "Month and name" when it stopped working. Set it back to defaults and back again to "Month and name" and it worked again.

  6. vTz
    Member
    Posted 3 years ago #

    Thanks hussong. You've been a great help, my site is working again :)

  7. hussong
    Member
    Posted 3 years ago #

    Happy to hear that sharing my experience was helpful, vTz :-)

  8. litemotiv
    Member
    Posted 3 years ago #

    I ran into this problem too, it took me a while to find out that the following lines:

    RewriteEngine On
    RewriteBase /

    Were removed from the # BEGIN WordPress block, so all permalinks were failing consequently. Flushing permalinks did not fix it for me.

    wp-supercache should probably restore that on uninstall.

  9. LilOle
    Member
    Posted 3 years ago #

    How do I get rid of this plugin? The update has made it basically inoperable and don't send me a long line of code because that's not how I work.

  10. hussong
    Member
    Posted 3 years ago #

    You can find step-by-step uninstallation instructions here: http://wordpress.org/extend/plugins/wp-super-cache/other_notes/

  11. LilOle
    Member
    Posted 3 years ago #

    This would be helpful if it didn't contain a long list of things that need to be done with code. You might as well be writing in Martian.

  12. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    So, which part are you having trouble with? Have you found your wp-config.php? It's usually in the same directory that WordPress is installed in. Edit that like you would any other file on your server and remove the line that mentions WP_CACHE.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic