WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Site offers zipped file rather than displaying home page (9 posts)

  1. headcrowny
    Member
    Posted 3 years ago #

    This is 2nd query - I put the earlier one on your blog and now realize this is the appropriate venue.

    Updated WP SC yesterday and clicked a couple of "recommended" boxes. After today's post came due visitors to the site got "This site wants to send you a zipped file, accept?" Deactivating SC fixed the issue. I then reactivated it without checking anything. My site still worked fine but there were a few "warning ..." messages at the top of the SC admin page. Strangely, these disappeared when I deactivated and reactivated. But I now have a warning that there are lines in my .htaccess that reference Super Cache and that these should be addressed. These lines ARE there and were added a long time back as part of getting Super Cache operational. Is it the case now that all Super Cache entries in my .htaccess should be deleted? Or should I perhaps deactivate Super Cache and then reinstall fresh?
    Thanks

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Click on the advanced settings page. You're now using PHP caching. You can delete those rules but if you leave them in, the rewrite_rules will serve the cache files anyway.

    It's not an error, it's just a warning in case you don't want them there.

  3. headcrowny
    Member
    Posted 3 years ago #

    Thanks! Yep, I am (using PHP caching). So were the rules something that're now not needed or are they not needed only if one is PHP caching? Basically I don't really want or not want them there beyond wanting to do what's needed for Super Cache to work correctly with my site.

    As far as the "recommended" items, would it be reasonable to click one at a time, check performance, and if all seems fine, click on the next, and so forth?

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    You don't need them if you're using PHP caching, and yes, clicking those checkboxes one at a time and testing is always a good idea!

  5. headcrowny
    Member
    Posted 3 years ago #

    The key concern for me is that when I did the original alteration everything seemed fine until the next picture posted (when I was asleep) and Super Cache produced the unexpected "do you want a zipped file" instead of letting the site display normally. I post new content at midnight and am routinely asleep before that, only checking on the site at 5 in the morning. Is it possible to know which of the checkboxes might cause this behavior? Doing a refresh and immediately seeing that all is well (or not) would be fine but having to be unsure if something is going to go wrong at post time would be a bit nerve wracking. I could, clearly, alter the post time (to when I'm awake) but I'd prefer that the posts go up on the usual schedule.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    headcrowny - disable compression on the advanced settings page.

  7. tmaster
    Member
    Posted 3 years ago #

    In PHP mode I am getting the ZIP download message on all pages. I had to go back to mod_rewrite to get the compression to work.

    I think the compression is broken in PHP mode. Something is wrong with the headers.

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Can you check the headers when in PHP mode for me? The headers work fine for me. The Firefox Live HTTP Headers extension is handy for checking.

  9. tmaster
    Member
    Posted 3 years ago #

    I switched it back into PHP and am unable to duplicate the error. On both of the websites it was doing it on.

    Its working fine now.

    I have no ideal why it was doing that before.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic