WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Sidebar disappears on pages with comments in IE when supercache is on (7 posts)

  1. drummergirl
    Member
    Posted 2 years ago #

    OK so I've got an IE problem - surprise! When I turn supercache on, the sidebar disappears but only in IE and only on pages that also have comments.

    To make sure it wasn't a widget conflict, I removed the widget code and set it to display some text. Still no love. The same sidebar displays fine in IE on pages that don't have comments enabled.

    If I disable comments for the page, the sidebar returns. So apparently they don't like each other.

    Any ideas on making this work? I have to leave Supercache off for now. :(

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    You need to debug your site as I haven't a clue what would cause that to happen for one browser. Is one browser logged in and the other logged out?

    Check your PHP error log, maybe there's an error somewhere?

  3. drummergirl
    Member
    Posted 2 years ago #

    No errors but I ran a few experiments and found the culprit...

    I am using WP-FB-AutoConnect which loads just after the comment box. I noticed on those pages that were missing the sidebar that the footer was also missing. I disabled the WP-FB-AutoConnect plugin and deleted the cache. Sure enough, the cached page loads fine. As soon as I turn WP-FB-AutoConnect back on, the sidebar and footer go missing.

    So....it works fine with caching off, but for some reason it's not working with the caching on. I'll continue testing to see if I can make them play nice together.

  4. drummergirl
    Member
    Posted 2 years ago #

    I did some isolated testing and it turns out that it’s not a conflict with supercache that’s causing the sidebar to disappear in IE. I also have WP minify and after rigorous testing, I can replicate this issue by turning the html minification on and then clearing the minification cache and then clearing supercache.

    Removing supercache from the equation, I can replicate it every time by turning the html minification on and then clearing the minification cache. I’ve now left the html minification off and turned supercache back on and the problem is resolved.

  5. miketopher
    Member
    Posted 2 years ago #

    drummergirl, im having this same issue but im not sure how it is you fix this, i did use wp minify, but iv since removed the plugin.

  6. drummergirl
    Member
    Posted 2 years ago #

    I don't use the WP-FB-AutoConnect plugin anymore. Sorry.

  7. miketopher
    Member
    Posted 2 years ago #

    oh im not using auto connect either. only FB plugin i use is a OG plugin for FB OG tags. .

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic