WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Should SuperCached page URLs contain /supercache/ ? (6 posts)

  1. Fredo754
    Member
    Posted 4 years ago #

    Hi:

    I installed Supercache on a client's site. It appears to be working, but perhaps incorrectly?

    When logged in as admin, a specific page URL displays as:
    http://www.limitstogrowth.org/articles/2010/08/11/crime-victim-dad-tells-his-story-about-open-borders-terrible-cost/

    When not logged in, the same page URL displays as:
    http://www.limitstogrowth.org/wp-content/cache/supercache/www.limitstogrowth.org/articles/2010/08/11/crime-victim-dad-tells-his-story-about-open-borders-terrible-cost/index.html

    Both pages contain in the source:
    <!-- Cached page generated by WP-Super-Cache on 2010-08-14 17:00:39 -->

    Now it may be obvious, but I could not find it documented anywhere that the URL would be changed for cached pages. The owner does not want the changed URL because she and others copy and paste the URL and want the primary URL.

    Is this perhaps an .htaccess mod rewrite configuration error? I have checked the installation against the install doc several times and everything looks ok.

    Also, I'm getting 5 second page load times or longer (via Pingdom.com), so it seems that cache is not working that well. (I manage the server and know that loads are not excessive).

    Thank you very much,

    Fred

  2. Fredo754
    Member
    Posted 4 years ago #

    Well, I'm still stuck. Help would be appreciated!

    Since starting this thread, I have upgraded Supercache from 0.9.9 to the current 0.9.9.3. I also repopulated .htaccess with rules from the current release. The Supercache control panel test says that it is working.

    This thread suggesting disabling all plugins:
    Supercache appended to URL

    I did that and the problem remained.

    (By the way, I would certainly donate to the developer, if I could get Supercache working correctly).

    Thanks in advance,

    Fred

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    Check your .htaccess rules and your plugins. That is not supposed to happen. I don't know why it is.

  4. Fredo754
    Member
    Posted 4 years ago #

    Hi:

    I previously disabled all plugins except Supercache and the problem remained. Just now I did a diff between .htaccess and the rules displayed under View Mod Rewrite Rules in the Supercache control panel. The rules are in .htaccess correctly. Same thing for cache/.htaccess.

    Any suggestions on how I can debug this problem?

    Thanks,
    Fred

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 4 years ago #

    You could try enabling mod_rewrite logging in Apache but you need to be root to do that and the output isn't easy to read.

    There's also a debug system built into WP Super Cache that may help. It's on the admin page.

  6. Fredo754
    Member
    Posted 4 years ago #

    Thanks. I'll do that as time permits. I'll post a solution if I find one.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic