WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Server Time & Expiry Time & Garbage Collection seems off (7 posts)

  1. Joe
    Member
    Posted 2 years ago #

    In the WPSC Advanced screen the "Current server time is: 2012-01-21 04:36:24"

    This is exactly 8 hours ahead of the actual server time, which seems like basically UTC.

    In the General Settings for WordPress Timezone is set to UTC-8

    I want to have the garbage collection run at 2am daily but this timing issue seems to be causing a problem.

    Any ideas on how to fix this?

    Thank you!

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    That date/time is generated by "date( 'Y-m-d H:i:s', time() )" so I presume that wp-cron works off the WordPress (local) time. Did you try setting the GC to 2am?

  3. Joe
    Member
    Posted 2 years ago #

    Hi and thanks for looking at this.

    I doesn't look like the server time is being picked up right by the plugin. I'm using 9am instead of 2am is because as you can see the Current Server Time is show by the plugin is not correct. It is showing me UTC, not PST.

    Here's what the settings display:

    Current server time is: 2012-01-27 01:57:43
    Next scheduled garbage collection will be at (YY-MM-DD H:M:S): 2012-01-27 09:00:00
    Cache Timeout: 43200
    Scheduler: Clock: 09:00
    Interval: Hourly (BTW this seems like another bug, because I have tried changing this interval to "Daily" but it doesn't stick, every time I load the settings it is back to Hourly on the drop down. Any idea how to fix this?)

    In the WP General Settings I have these Settings:

    Timezone: Los Angeles
    UTC time is 2012-01-27 1:57:21
    Local time is 2012-01-26 17:57:21

    Side (main) note: Actually this is pretty much the main reason I'm trying to fix this timing issue. Every day precisely at 5pm the website comes to a complete crawl and index.php starts using up about 30% of CPU. This is really something major that I need to address soon. I'm guessing this has to do with cached pages being recreated. If you have any tips on how to fix this issue I would really appreciate it. Is there maybe a way to log what exactly WSC GC is doing and when?

    Also, what does the Notification Emails checkbox do?

    Thank you

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    I've updated the plugin. I tried making it smart and accounting for the user's timezone but went around and around in circles. Instead I made it clearer that times are UTC, showed the blog (local) time and UTC time in the same was Settings->General does.

    The interval (daily/hourly etc) is fixed in the dev version so please try that if you want to test this.

    The notification email is a summary of how many files were deleted during GC. Handy for debugging..

  5. Mike
    Member
    Posted 2 years ago #

    Instead I made it clearer that times are UTC, showed the blog (local) time and UTC time in the same was Settings->General does.

    Hmmm, I have UTC-5 set in Settings->General, but WP Super Cache still shows UTC time. (And it's not clear that it's UTC, it's labeled "Current server time," which is incorrect.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm, maybe you updated from the development zip file before the zip file was updated as UTC time is shown all over the "advanced settings->Expiry Time & Garbage Collection" section?

  7. Mike
    Member
    Posted 2 years ago #

    Oh, I didn't catch the fact that the change was made just in the development version. Sorry, my bad.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic