WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] sem.acquire() warning while creating/updating pages (7 posts)

  1. loewenhertz
    Member
    Posted 6 years ago #

    I installed the latest version of WP-Super-Cache, running on WordPress 2.5 german version. Installation was easy, manually added advanced-cache.php to /wp-content, all caching works well and I can see the folders and files created by WP-Super-Cache.

    Only when I create or modify a new page, I get an error at /wp-admin/post.php:

    Warning: sem_acquire() [function.sem-acquire]: failed to acquire key 0x152b: Permission denied in /.../wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 106
    
    Warning: sem_release() [function.sem-release]: SysV semaphore 69 (key 0x152b) is not currently acquired in /.../wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 120
    
    Warning: Cannot modify header information - headers already sent by (output started at /.../wp-content/plugins/wp-super-cache/wp-cache-phase2.php:106) in /.../wp-includes/pluggable.php on line 694

    Once I reload post.php, all changes appear both in the backend and on the site and it seems that WP-Super-Cache is generating a new version of the cached page.

    I have gone through the troubleshooting section of the plugin, but nothing helped me so far. As it will confuse the guys who will need to update the blog i like to know if anybody knows whats happening here.

    Cheers and thanks for any suggestions.

  2. Donncha O Caoimh
    Member
    Posted 6 years ago #

    Edit wp-content/wp-cache-config.php and uncomment the line starting with "$use_flock".

    I'm going to add this to the trouble shooting section of the readme.txt

  3. loewenhertz
    Member
    Posted 6 years ago #

    Seems like this has done the trick! Thank you (mostly for this great plugin!!)

  4. sciencebase
    Member
    Posted 6 years ago #

    I (foolishly) upgraded the plugin to version 2.6.1.0 (August 20, 2008) before upgrading WP itself to 2.6.1 and saw this error on my static homepage in root, but not on pages in the WP blog folder or elsewhere on the site, which was odd. Your hack seems to have fixed things though. I wonder whether it has anything to do with the fact that I'm using the technique described here

    http://www.sciencetext.com/how-to-make-html-pages-work-like-wordpress.html

    to make WordPress render on normal html pages...

  5. Donncha O Caoimh
    Member
    Posted 6 years ago #

    sciencebase - semaphores aren't supported on all hosts which is why you have to fall back to file locking. It's just changing a configuration option, no hacking really.

    Nothing to do with your html pages at all!

  6. mikejandreau
    Member
    Posted 5 years ago #

    This fix seems to have worked for me, temporarily.

    Now, I get the error the first time a page is loaded. Refreshing makes it go away. But any differet pages being loaded result in that same error until refreshed.

    I should also note that the pages that result in the error are pages *outside* of WordPress, that I include the WordPress header in, and execute a "recent comments" plugin.

    Any suggestions?

  7. imsavagerawr
    Member
    Posted 5 years ago #

    I dont understand what you mean by uncomment are those the " // " lines?

    Quote:

    Edit wp-content/wp-cache-config.php and uncomment the line starting with "$use_flock".

    I'm going to add this to the trouble shooting section of the readme.txt

Topic Closed

This topic has been closed to new replies.

About this Topic