WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Scheduled posts with no logged in activity results in no homepage cache up (7 posts)

  1. skippybosco
    Member
    Posted 3 years ago #

    All of the posts on our blog are scheduled (in 30 minute increments), sometimes days in advance. We only allow guest commenting (ie. reader accounts). As a result hours (or days) can go by without anyone logging into WordPress.

    While cron is running and posts are being published on schedule (and being republished on Facebook, Twitter, etc) the super cached home page is not expiring as I would expect. As soon as someone logs into WordPress (admin, writer, etc), however, the home page is marked as expired and a new page is generated.

    I've seen a few other mentions of schedule posts and home page not expiring, curious if there is any special configuration or separate cron I should be running for this type of setup.

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Do you have "Only refresh current page when comments made." on the settings page checked?

  3. skippybosco
    Member
    Posted 3 years ago #

    Thank you for your reply. Yes, I do have "only refresh current page when comments are made" checked. I had assumed that a scheduled post publishing would expire the home page and force a refresh, is my logic in error?

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    It should, but that's probably a bug as the same functions are used in both actions.

  5. skippybosco
    Member
    Posted 3 years ago #

    I've seen a few SVN updates since this topic was started, but no commit messages specifically mentioning this bug.

    Specifically homepage not being updated when two conditions are met:

    1) All posts are scheduled (in my case, 1 every 30 minutes)

    2) No actions taken for hours or sometimes days which require someone to log in to WordPress (all comments to the site are done via guest comments.

    Considering just having something delete the cache/mydomain.com/index.html every 30 minutes.. but wanted to follow up to see if there was a more suitable option in the works.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Sorry, I misunderstood your first email. You need to uncheck "Only refresh current page when comments made". as the homepage won't be updated ever until preloading happens again. That's basically what that option means. Only the post will be updated when comments are left.

    If you still want to leave that on, you could add a function that hooks on to publish_post that deletes the cached file for the homepage.

  7. skippybosco
    Member
    Posted 3 years ago #

    Thanks, I'll try that out, was confused about that setting and what all was "refreshed" if that was left unchecked. I appreciate the clarification.

    On a side note, did the latest upgrade from SVN, very happy to see the integration of OSSDL CDN Off Linker. Had been using that plugin independent of WP Super Cache for a while now. Good stuff!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic