WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Problem with german umlaut? (9 posts)

  1. Viktor Leberecht
    Member
    Posted 2 years ago #

    Hello,

    i have been using your caching plugin without any troubles on two blogs for over a year, perfect.

    I have now set up a new blog. I´m using the same theme, same plugins), and of course super cache with exactly the same settings as on my other blog

    But other than on my other german language blog (http://viktor-leberecht.de) on my new blog (http://polygamie-ist-gut-fuer-sie.de) i am experiencing a problem with the german umlaut (ä, ü, ö) as soon as i turn on caching. Instead of the umlaut ü i get ü and so on with the other umlaute.

    If you had a moment to look at it and any idea how to fix the problem that would be very nice.

    Kind regards, Viktor

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Can you try the development version at http://downloads.wordpress.org/plugin/wp-super-cache.zip and make sure that "Remove UTF8/blog charset support from .htaccess file. Only necessary if you see odd characters or punctuation looks incorrect. Requires rewrite rules update." is not checked on the advanced settings page.

    It will need to update the rewrite rules but that should fix things.

  3. Viktor Leberecht
    Member
    Posted 2 years ago #

    Thx for quick reaction. Sorry but I'll be slower and will probably only get to this during the weekend.

  4. Viktor Leberecht
    Member
    Posted 2 years ago #

    Hello,

    i installed the plugin, and i have tried it with IE and Firefox and Chrome, always the same thing happening, on a fully updated Win 7 Laptop

    -First s you said without "Remove UTF8 ..."
    Result: Same problem: odd characters showing.

    -tried with the "Remove UTF 8 .." settting
    Result: Same problem

    Now here is where it gets odd, and i forgot that in my first descrition of the problem:

    When i call up the homepage the first time, it looks fine
    I checked the source code, tells me:
    <!-- Dynamic page generated in 0.363 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2012-05-13 15:29:24 -->
    <!-- Compression = gzip -->

    Then if i call up either the home page again or a sub page the odd characters appear again, and the real strange thing is, that according to the source it is the same cached page as before:
    <!-- Dynamic page generated in 0.363 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2012-05-13 15:29:24 -->
    <!-- Compression = gzip -->

    The only differrence i was able to find in the source code is at the beginning of the source code (i marked the parts that change). When calling the page first it begins like this:

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    When calling it up the second time the source code is different:

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    so the second time even thoug it is the same cached page (according to the time stamp) it suddenly has the odd characters.

    I stil have no idea, because as i said before, i am using the same version of wordpress, the same plugins except for a few not yet installed or set up), the same settings as on my other german language blog.
    Any idea?

    Kind regards, Viktor

  5. Viktor Leberecht
    Member
    Posted 2 years ago #

    Newest development: it is happening on my other sites (german and english too, http.//viktor-leberecht.de and http://viktor-leberecht,com) after i removed some widgets, cleared the cache manually and started preload manually.

    I also just saw that the code was removed from my former post, so here is what changes in a shorter description.
    When calling a page up for the first time everything is fine on the page view as well as in the source code.
    But when calling up the same page a second time there are these odd characters in the page view and in the source code, like here:

    <link rel="alternate" type="application/rss+xml" title="Polygamie ist gut für Sie » Feed" href="http://polygamie-ist-gut-fuer-sie.de/feed/" />
    <link rel="alternate" type="application/rss+xml" title="Polygamie ist gut für Sie » Kommentar Feed" href="http://polygamie-ist-gut-fuer-sie.de/comments/feed/"

    Any suggestions?

  6. Viktor Leberecht
    Member
    Posted 2 years ago #

    sorry, typos, the websites are:

    http://polygamie-ist-gut-fuer-sie.de

    http://viktor-leberecht.de

    http://viktor-leberecht.com

    It only happens when caching is turned on, so i assume it must be something to do with super cache.
    But could it also be that it has to do with how super cache and my theme (Suffusion) interact?

    Kind regards, Viktor

  7. Viktor Leberecht
    Member
    Posted 2 years ago #

    To make it all a bit more weird (at least for me): i have a blog just for testing, again with all the same settings for wordpress, the theme, super cache and most of the plugins. On that blog i don´t have these problems. :-)
    http://test.viktor-leberecht.de/

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    I just fixed a bug in the UTF-8 code so it probably wasn't updating your .htaccess file. Can you give the development version a go again? It should update with the new code in about 20 minutes after this post ..

  9. Viktor Leberecht
    Member
    Posted 2 years ago #

    You did it.

    I have tested it on
    http://polygamie-ist-gut-fuer-sie.de
    and everything is fine.

    Great job, thank you very much for your help and the work you put into it.

    Should i manually install this version on my other blogs or will this version become an official release that will show up as an update?

    Kind regards and thanks again, Viktor

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic