WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Problem with 2.8.4 and Super Cache 0.9.6.1 (12 posts)

  1. sops21
    Member
    Posted 4 years ago #

    I've just upgraded to 2.8.4 because of the Worm problem. At the same time I've upgraded WP Super Cache to the latest version. Now, when I try and change any option in the settings, I can get the Following Error:

    "You do not have sufficient permissions to access this page."

    I've been playing around with it for a while. Uninstalled, Installed, activated the plugin disabled it, etc. No help. I still the the permission error when doing anything in the admin.

    I noticed something odd while playing around with it, whenever I try and change a setting and hit any of the buttons to apply the change, or clear the cache etc, the url that it is trying to go to is:

    http://www.mysitehere.com/blog/wp-admin/options-general.php?page=wpsupercache?page=wpsupercache

    Is that the correct url? it looks like its just repeating itself. Perhaps that is what is wrong.

    Any one have any ideas?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Pinoy.ca
    Member
    Posted 4 years ago #

    I think it would help us to know where you see this error message.

    As for the other thing, is this repeat happening only in Super Cache or also in your other plugin option screens?

  3. sops21
    Member
    Posted 4 years ago #

    It only occurs when I hit any of the buttons such as "Update Status, Clear Cache, Delete Expired, etc"

    It only occurs in Super Cache.

    Let me know if any other questions.

  4. Donncha O Caoimh
    Member
    Posted 4 years ago #

    That's strange. sops21 - do you see the "page=wpsupercache?page=wpsupercache" in the forms of the admin page? Not sure how that's happening.

  5. sops21
    Member
    Posted 4 years ago #

    What do you mean by "the forms of the admin page". I viewed the source of the page and the form action is "page=wpsupercache?page=wpsupercache".

    Another thing that I noticed today on another blog that I run. That the plugin wp-flexible-upload has the same problem when saving any options. It gets the error: "You do not have sufficient permissions to access this page." as well.

    I don't know if that helps at all, but I figure the more information the better.

  6. Donncha O Caoimh
    Member
    Posted 4 years ago #

    That helps. Not sure why you're getting that error but it should be easy enough to fix.

  7. crossdriven
    Member
    Posted 4 years ago #

    I am having the same problem. I am getting this at the top of my page:

    define('WP_CACHE', true); //Added by WP-Cache Manager

    It stopped loading my background and killed my site for a while. If you could help me get rid of this I would appreciate it.

    My blog is http://www.crossdrivenradio.com

  8. crossdriven
    Member
    Posted 4 years ago #

    This is what I see from wp-admin trying to login:

    define('WP_CACHE', true); //Added by WP-Cache Manager
    Warning: Cannot modify header information - headers already sent by (output started at /home/crossdri/public_html/crossdrivenradio/wp-config.php:3) in /home/crossdri/public_html/crossdrivenradio/wp-login.php on line 290

    Warning: Cannot modify header information - headers already sent by (output started at /home/crossdri/public_html/crossdrivenradio/wp-config.php:3) in /home/crossdri/public_html/crossdrivenradio/wp-login.php on line 302

    Warning: Cannot modify header information - headers already sent by (output started at /home/crossdri/public_html/crossdrivenradio/wp-config.php:3) in /home/crossdri/public_html/crossdrivenradio/wp-includes/pluggable.php on line 662

    Warning: Cannot modify header information - headers already sent by (output started at /home/crossdri/public_html/crossdrivenradio/wp-config.php:3) in /home/crossdri/public_html/crossdrivenradio/wp-includes/pluggable.php on line 663

    Warning: Cannot modify header information - headers already sent by (output started at /home/crossdri/public_html/crossdrivenradio/wp-config.php:3) in /home/crossdri/public_html/crossdrivenradio/wp-includes/pluggable.php on line 664

    Warning: Cannot modify header information - headers already sent by (output started at /home/crossdri/public_html/crossdrivenradio/wp-config.php:3) in /home/crossdri/public_html/crossdrivenradio/wp-includes/pluggable.php on line 865

  9. crossdriven
    Member
    Posted 4 years ago #

    My site was totally wasted. couldn't login or display my blog. Thankfully, Bluehost was able to roll back yesterday's backup and restore my site.

    I'm going to blog and podcast about how aweful this plugin is for sure!

  10. Donncha O Caoimh
    Member
    Posted 4 years ago #

    crossdriven - you should have read the error log more closely. The "define('WP_CACHE', true)" line must have been outside any PHP tags. Classic whitespace problem unfortunately.

    Move the line down and it'll work.

  11. eharmonyblog
    Member
    Posted 4 years ago #

    Oops, cross post. Please delete

  12. crossdriven
    Member
    Posted 4 years ago #

    @donncha unfortunately I am not a programmer so I don't understand all of the codespeak. I searched everywhere and didn't find that error, perhaps that would be a good entry in your faq.

    After that ordeal, I don't think I'm going to try it again, best wishes though..

Topic Closed

This topic has been closed to new replies.

About this Topic