WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
plugin is eating my RAM memory (5 posts)

  1. AlAmRi
    Member
    Posted 2 years ago #

    hello ,
    i have my own server with only one website using WP
    i have installed this plugin and it work perfect at the beggining
    after 18 hours the server went down offline due to memory usage
    when i disable the plugin the website back online again,
    i tried to re-install the plugin , and show me the same problem ( high memory usage )
    what should i do ?
    i have high traffice about 30,000/ day
    i really need caching plugin

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. admintiger
    Member
    Posted 2 years ago #

    I was having the same problem and found it was because the cache was continually being built, deleted, and rebuilt in a never-ending cycle. Installing the trunk (new, unreleased) version of WP Super Cache corrected that problem at several of my sites. I am not necessarily recommending installation of the trunk version at production sites, because the developer hasn't released it yet and there could be bugs I don't know about. I am just letting you know how I overcame the problem you are having.

  3. AlAmRi
    Member
    Posted 2 years ago #

    thank you admintiger
    i used the offical release:
    http://wordpress.org/extend/plugins/wp-super-cache/

    i have 16 cpu and 8GB RAM
    now this plugin is eating them both, CPUs and RAMs

    when i disable it the server back normal with some high CPU usage only
    and at peak time the CPU become high and server down,
    that's why i need caching plugin
    PLEASE I NEED HELP I CAN'T RENT OTHER SERVER $$$

  4. millstreettown
    Member
    Posted 2 years ago #

    i don't know if ye've the same problem as me, but we've been having some real slowdown issues in the last few weeks, especially when we go to the post-new.php page.

    so i tracked it down that WP Super Cache was trying to delete all autodraft posts (over 7 days) in the background. in this it does a purge on all the supercache files in wp-content/supercache folder ... so it was iterating through all the folders in there. not good for us because there was roughly 2500 folders in there, and it was taking about 8 seconds. for some reason it was doing this twice, but that didn't bother me too much.

    the matter was made much worse when it decided to delete multiple drafts at the same time (sometimes up to 20 or more), which was a delay of 20 * 16 seconds ... which is usually a timeout ... as the RAM etc on the server goes mental.

    end of the day, i deleted the cache (in the supercache settings pages), and everything sped up, but i guess i'll have to be doing that kind of often now until the problems are fixed.

    but it would be good if wpsupercache cleaned up the folders after itself when it was deleting expired supercache files. that would solve some of the problems ...

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Try the dev version as it may make a difference to this problem.

    http://downloads.wordpress.org/plugin/wp-super-cache.zip

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic