WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] PHP Warning of print_f() function on line 408 in wp-cache.php (4 posts)

  1. Gautam
    Member
    Posted 4 years ago #

    I installed the WordPress Mobile Edition Plugin, activated it. Then checked the option for Mobile Device Support and then I am receiving this error:
    Rewrite rules must be updated

    The rewrite rules required by this plugin have changed or are missing. Mobile support requires extra rules in your .htaccess file, or you can set the plugin to half-on mode. Here are your options (in order of difficulty):

    1. Set the plugin to half on mode and enable mobile support.
    2. Delete the plugin mod_rewrite rules in /home/.../.htaccess enclosed by # BEGIN WPSuperCache and # END WPSuperCache and let the plugin regenerate them by reloading this page.
    3.

    Warning: printf() [function.printf]: Too few arguments in /home/.../wp-content/plugins/wp-super-cache/wp-cache.php on line 408

    RewriteCond %{HTTP_user_agent} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*

  2. Donncha O Caoimh
    Member
    Posted 4 years ago #

    This is a minor warning but I've fixed it in trunk. You can find the fixed wp-cache.php here but it's so minor that it's not worth upgrading.

    Hopefully most users won't have "display errors" on and won't see this warning.

  3. neville
    Member
    Posted 4 years ago #

    I saw that text as well after upgrading the plugin to version 0.9.9. I already have the WP Mobile Edition installed so I followed option 2:

    2. Delete the plugin mod_rewrite rules in /home/.../.htaccess enclosed by # BEGIN WPSuperCache and # END WPSuperCache and let the plugin regenerate them by reloading this page.

    As soon as I refreshed the Supercache settings page, I got an immediate 500 server error. If I tried to load the live blog, I got a 500. Trying any page on the domain, a 500 error.

    I deleted the htaccess file and restored the backup I'd made with no changes. 500 error gone, everything loads as normal.

    Trying to figure out what I did wrong. I just deleted the text as noted in option 2.

    Something else I should have (not) done?

  4. Donncha O Caoimh
    Member
    Posted 4 years ago #

    neville - saw your tweet about it this morning! I don't know what may have gone wrong there. Out of paranoia I tried the same. Deleting from the "IfModule mod_rewrite.c" down to the "/IfModule" line. I refreshed and the admin page appeared again asking me to update the .htaccess file.

    Can you email me your backup .htaccess? Just so I can see what was there first? donncha at ocaoimh.ie will get to me!

Topic Closed

This topic has been closed to new replies.

About this Topic