WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] PHP or legacy for use with Bad Behavior? (3 posts)

  1. nv1962
    Member
    Posted 2 years ago #

    I'm on a shared host and so can't use more advanced object / DB caching methods (with shared hosts, memcached or APC is bound to end up in trouble sooner or later) and therefor am more than happy with WP Super Cache or WSC.

    The thing is, I (unfortunately) have to use Bad Behavior also and that's another reason I'm happy with WSC. However, I'm not sure whether that therefor inexorably means setting WSC to legacy mode, or if PHP mode would work too. And on a shared hosting package, every little bit helps, so if PHP really works with the WSC plugin active, I'd be happy, but I want to be 100% sure, first.

    Can anyone provide me input on that?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Why do you need to use Bad Behavior? You could use Akismet and Cookies for Comments to combat comment spam. There is a built in plugin that supports BB in Supercache, activate that and it sets things up for you.

  3. nv1962
    Member
    Posted 2 years ago #

    I'm not really worried about spam comments (no comments allowed, unless you're logged in, and you can't log in, unless you've paid up your membership dues) what I am worried about are malbots. Bad Behavior checks, as the name suggests, for suspicious fingerprints in behavior and denies or admits accordingly. Moreover, it checks IPs (via a fast DNS type query) against a blacklist for known bad IPs. Bad Behavior actually works great alongside Akismet; they complement each other well. But like many plugins, you have to know why you use it - and how to set it properly. Anyway...

    I noticed that the BB plugin didn't set WSC to legacy mode on my site, so now that you've confirmed that the BB plugin really sets things up as required, I'll just keep it in PHP mode then.

    It's just that the text next to the BB plugin suggests that it ought to be used in legacy, that is why I asked here.

    Thanks again Donncha!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic