WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Permlink Structure Error (19 posts)

  1. Didier77
    Member
    Posted 3 years ago #

    After installing last version, I am no more able to view/modify settings and get error:

    "Permlink Structure Error

    A custom url or permalink structure is required for this plugin to work correctly. Please go to the Permalinks Options Page to configure your permalinks."

    I don't want to change my permlink settings as many pages/articles use internal links.

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    So are you using ?p=xxx for your urls? Those links will still work even when you have custom permalinks!

  3. Didier77
    Member
    Posted 3 years ago #

    Ok, thanks. Any recommendation of permalinks I can use? I envisage /%postname%/. Is it ok?

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Yeah, that's fine.

  5. Didier77
    Member
    Posted 3 years ago #

    Thanks a lot!

  6. Pavel Holoborodko
    Member
    Posted 3 years ago #

    But how about PR?
    Will pages loose it after moving to pretty permalinks?
    Or WP SuperCache & WordPress (3.0.1) do 301 redirections automatically for all posts and pages?

    Information in the web is contradictory on the subject. Could you help please?

    Thank you for all the hard work on Super Cache. I've been using it for two years.

  7. Pavel Holoborodko
    Member
    Posted 3 years ago #

    So, nobody know the answer?
    Could someone give me a link to clear explanation if this question really stupid and doesn't deserve to be answered here.

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    It's pretty easy to test, look at the headers sent by the server when you request a ?p=xxxx request and it redirects. WordPress sends a 301 redirect so the PR is transferred.

  9. Pavel Holoborodko
    Member
    Posted 3 years ago #

    Thank you very much for your reply and all the efforts creating WP Super Cache.

  10. skippybosco
    Member
    Posted 3 years ago #

    I would advise against just using /%postname%/ as your URL structure.

    You can read a bit about it here:

    http://codex.wordpress.org/Using_Permalinks

    "For performance reasons, it is not a good idea to start your permalink structure with the category, tag, author, or postname fields. The reason is that these are text fields, and using them at the beginning of your permalink structure it takes more time for WordPress to distinguish your Post URLs from Page URLs (which always use the text "page slug" as the URL), and to compensate, WordPress stores a lot of extra information in its database (so much that sites with lots of Pages have experienced difficulties)."

    For a balance of performance and SEO I typically recommend:

    /%year%/%month%/%post_name%/

    or http://mydomain.com/2010/11/post_name

  11. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    skippybosco - going against all the recommendations I use /postname/ as the permalink structure on my blog and it works well. Once all posts are preloaded they're served by mod_rewrite rules anyway so there's little processing to be done :)

  12. Pavel Holoborodko
    Member
    Posted 3 years ago #

    I've installed following permalinks structure:
    /%year%/%monthnum%/%day%/%postname%/

    It works for posts, e.g.:
    http://www.holoborodko.com/pavel/2009/07/17/rikugien-garden/

    But URLs for pages became /%postname%/ anyway:
    http://www.holoborodko.com/pavel/quicklatex/

    I've checked HTTP Headers by Fiddler - /?p=xxxx are being correctly redirected - so I'm happy.

    It seems like WP makes permalinks for pages of /%postname%/ style regardless of user settings.
    Or am I missing something?

  13. Pavel Holoborodko
    Member
    Posted 3 years ago #

    Just noticed,

    Sometimes Fiddler give error message on loading page (in IE) cached by Super Cache (in preload mode):
    "The Server did not return properly formatted HTTP Headers. HTTP headers
    should be terminated with CRLFCRLF. These were terminated with LFLF."

    Is it a big deal? Page are being loaded properly in the browser anyway.
    When I load page in FireFox - no complains from Fiddler appear.

  14. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    advanpix - pages are always served that way. I'm not sure about the headers as Supercache uses Apache modules to serve them and I would have thought they'd work properly but I'll keep it in mind.

  15. Pavel Holoborodko
    Member
    Posted 3 years ago #

    Thanks for clarifying!

  16. Google Commentator
    Member
    Posted 3 years ago #

    Hi there,

    I am trying to resolve the same issue as above. My default setting is http://www.websitename.com/?p=123. I need to understand this in layman's terms, so would I highlight custom struture and change my permalink address to http://www.websitename.com/%postname%/ to get this error fixed? If you could explain it with the example I've used, and in layman's terms, it would be greatly appreciated.

  17. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Yeah, just go to the Permalinks page and put /%postname%/ in the custom permalinks textbox.

  18. Google Commentator
    Member
    Posted 3 years ago #

    Hi again,

    Thank you! Could you help me with another issue with wp supercache. It says under the advanced section, and within "directly cached files", that my site: /home/websitename/websitename.com is "writable". "Please make it readonly after your page is generated as this is a security risk." Could you tell me, in layman's terms, how to fix this?

    Thank you!

  19. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Use the chmod command through your ftp client. Remove the World and Group writeable flags, or 755 if you can enter the numbers.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic