WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Pages not cached - User Agents issue? (8 posts)

  1. RainbowMode
    Member
    Posted 2 years ago #

    Hi,

    I'm still trying to find a solution regarding the timestamps & frontend pages not displaying (http://wordpress.org/support/topic/plugin-wp-super-cache-pages-cannot-be-dispayed-timestamps-cache-issue?replies=1) by starting a new preload cache.

    After about one hour, only 5 pages were cached. Is this normal?
    I took a look in the debug file and, if I understand it correctly (sorry, I'm not a code expert), it seems that several pages are not cached.

    For example:

    10:55:17 /nl/home-nl/ supercache dir: /homez.547/rainbowm/www/wp-content/cache/supercache/www.rainbowmode.com/nl/home-nl/
    10:55:17 /nl/home-nl/ No wp-cache file exists. Must generate a new one.
    10:55:18 /nl/home-nl/ In WP Cache Phase 2
    10:55:18 /nl/home-nl/ Setting up WordPress actions
    10:55:18 /nl/home-nl/ USER AGENT (Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)) rejected. Not Caching

    or

    10:58:53 /the-virgin-dolls/blow-your-mind/ supercache dir: /homez.547/rainbowm/www/wp-content/cache/supercache/www.rainbowmode.com/the-virgin-dolls/blow-your-mind/
    10:58:53 /the-virgin-dolls/blow-your-mind/ No wp-cache file exists. Must generate a new one.
    10:58:54 /the-virgin-dolls/blow-your-mind/ In WP Cache Phase 2
    10:58:54 /the-virgin-dolls/blow-your-mind/ Setting up WordPress actions
    10:58:54 /the-virgin-dolls/blow-your-mind/ USER AGENT (Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)) rejected. Not Caching

    or

    11:00:39 /artiesten/the-virgin-dolls/ In WP Cache Phase 2
    11:00:39 /artiesten/the-virgin-dolls/ Setting up WordPress actions
    11:00:39 /artiesten/the-virgin-dolls/ USER AGENT (Mozilla/5.0 (compatible; AhrefsBot/3.1; +http://ahrefs.com/robot/)) rejected. Not Caching

    or

    11:07:36 /shop/tシャツ/ supercache dir: /homez.547/rainbowm/www/wp-content/cache/supercache/jp.rainbowmode.com/shop/tシャツ/
    11:07:36 /shop/tシャツ/ No wp-cache file exists. Must generate a new one.
    11:07:37 /shop/tシャツ/ In WP Cache Phase 2
    11:07:37 /shop/tシャツ/ Setting up WordPress actions
    11:07:37 /shop/tシャツ/ USER AGENT (Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)) rejected. Not Caching

    and so on...

    Why the pages are not cached because of the rejected user agent? Am I doing something wrong? Is there something I should change in the advanced settings? I only validated what was recommended and added rejected user agents for compatibility with WPTouch pro.

    I'm stuck...
    Thanks forward for your help!

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    You probably made a mistake when you entered the user agents.
    I think you should install the development version which has a couple of WPTouch fixes.

    Remove the user agents and enable the WPTouch wp-super-cache plugin. With that plugin active you shouldn't need to use rejected user agents. Keep an eye on your logs. Does that help?

  3. RainbowMode
    Member
    Posted 2 years ago #

    Thank you for this fast support.

    I deleted version 1.1 and uploaded/activated the development version (wp-super-cache.zip). It still shows version 1.1. Is this normal?

    Before installing the dev version, the WPTouch support was enabled in the plugins settings and I added the rejected user agents because of a warning compatibility message by WPTouch Pro. The guys from Bravenewcode told me that the support for WPTouch enabled by WP Super Cache was only for the free version. I'm using the Pro version, reason why I followed their instructions and added their list of user agents. Isn't it accurate?

    By installing the dev version, the user agents I added were automatically removed.

    I made a new cache test and... miracle! Without any other modification, the timestamps now matches!
    What happened?

    I then started a new preload cache. It seems really faster. After a few minutes, 86 pages were cached.

    So... a real improvment, yes it helps!

    But I'm not sure everything is fixed. I still see "strange" data in the debug file:

    12:33:53 /artistes/ffosmatika/ In WP Cache Phase 2
    12:33:53 /artistes/ffosmatika/ Setting up WordPress actions
    12:33:53 /artistes/ffosmatika/ Created output buffer
    12:33:54 /wp-cron.php?check=70abd84157c7dae3f61eb08da8bb2e91 In WP Cache Phase 2
    12:33:54 /wp-cron.php?check=70abd84157c7dae3f61eb08da8bb2e91 Setting up WordPress actions
    12:33:54 /wp-cron.php?check=70abd84157c7dae3f61eb08da8bb2e91 Supercache caching disabled. Only using wp-cache. Non empty GET request.
    12:33:54 /wp-cron.php?check=70abd84157c7dae3f61eb08da8bb2e91 URI rejected. Not Caching
    12:33:55 /artistes/ffosmatika/ Output buffer callback
    12:33:55 /artistes/ffosmatika/ Supercache disabled: GET or feed detected or disabled by config.
    12:33:55 /artistes/ffosmatika/ Writing non-gzipped buffer to wp-cache cache file.
    12:33:55 /artistes/ffosmatika/ Renamed temp wp-cache file to /homez.547/rainbowm/www/wp-content/cache/wp-cache-26884aa10963ea726b1f3163a5f52511.html
    12:33:55 /artistes/ffosmatika/ Sending buffer to browser
    12:33:55 /artistes/ffosmatika/ wp_cache_shutdown_callback: collecting meta data.

    or

    12:34:55 /artistes/the-virgin-dolls/blow-your-mind/ No wp-cache file exists. Must generate a new one.
    12:34:55 /artistes/the-virgin-dolls/blow-your-mind/ In WP Cache Phase 2
    12:34:55 /artistes/the-virgin-dolls/blow-your-mind/ Setting up WordPress actions
    12:34:55 /artistes/the-virgin-dolls/blow-your-mind/ Created output buffer
    12:34:57 /artistes/the-virgin-dolls/blow-your-mind/ Output buffer callback
    12:34:57 /artistes/the-virgin-dolls/blow-your-mind/ Supercache disabled: GET or feed detected or disabled by config.
    12:34:57 /artistes/the-virgin-dolls/blow-your-mind/ Writing non-gzipped buffer to wp-cache cache file.
    12:34:57 /artistes/the-virgin-dolls/blow-your-mind/ Renamed temp wp-cache file to /homez.547/rainbowm/www/wp-content/cache/wp-cache-7e5709ed287770e6478447ac3e68dee4.html
    12:34:57 /artistes/the-virgin-dolls/blow-your-mind/ Sending buffer to browser
    12:34:57 /artistes/the-virgin-dolls/blow-your-mind/ wp_cache_shutdown_callback: collecting meta data.
    12:34:57 /artistes/the-virgin-dolls/blow-your-mind/ Writing meta file: /homez.547/rainbowm/www/wp-content/cache/meta/wp-cache-7e5709ed287770e6478447ac3e68dee4.meta

    or

    12:33:59 /artistes/kelee/ Output buffer callback
    12:33:59 /artistes/kelee/ Supercache disabled: GET or feed detected or disabled by config.
    12:33:59 /artistes/kelee/ Writing non-gzipped buffer to wp-cache cache file.
    12:33:59 /artistes/kelee/ Renamed temp wp-cache file to /homez.547/rainbowm/www/wp-content/cache/wp-cache-7078f84570436b79db06f618e9c5ee94.html
    12:33:59 /artistes/kelee/ Sending buffer to browser
    12:33:59 /artistes/kelee/ wp_cache_shutdown_callback: collecting meta data.
    12:33:59 /artistes/kelee/ Writing meta file: /homez.547/rainbowm/www/wp-content/cache/meta/wp-cache-7078f84570436b79db06f618e9c5ee94.meta
    12:34:00 /artistes/revides/ supercache dir: /homez.547/rainbowm/www/wp-content/cache/supercache/www.rainbowmode.fr/artistes/revides/
    12:34:00 /artistes/revides/ No wp-cache file exists. Must generate a new one.
    12:34:02 /artistes/revides/ In WP Cache Phase 2
    12:34:02 /artistes/revides/ Setting up WordPress actions
    12:34:02 /artistes/revides/ Created output buffer
    12:34:04 /artistes/revides/ Output buffer callback
    12:34:04 /artistes/revides/ Supercache disabled: GET or feed detected or disabled by config.
    12:34:04 /artistes/revides/ Writing non-gzipped buffer to wp-cache cache file.
    12:34:04 /artistes/revides/ Renamed temp wp-cache file to /homez.547/rainbowm/www/wp-content/cache/wp-cache-4793e7c86a2471fbb93a25d9630f2d48.html
    12:34:04 /artistes/revides/ Sending buffer to browser
    12:34:04 /artistes/revides/ wp_cache_shutdown_callback: collecting meta data.
    12:34:04 /artistes/revides/ Writing meta file: /homez.547/rainbowm/www/wp-content/cache/meta/wp-cache-4793e7c86a2471fbb93a25d9630f2d48.meta

    Why this warning about "Supercache disabled: GET or feed detected or disabled by config"?

    When I refresh the cache contents stats, the pages above are listed.
    Why?

    Thanks again for your expertise!

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    I added support for the pro version in the dev version. I don't know why you're getting those warnings. There's something odd about your site I think!

  5. RainbowMode
    Member
    Posted 2 years ago #

    Update...

    20 minutes later, no new page cached it is stuck to 88 pages.

    I don't know why, I saw in the advanced settings a new warning message about the mod_rewrite rule and was asked to update the .htaccess file.

    When I see the debug info there's again data about user agents.

    For example:

    12:57:32 /ru/%D0%B0%D1%80%D1%82%D0%B8%D1%81%D1%82%D1%8B/skypearls/ USER AGENT (Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)) rejected. Not Caching

    or

    12:57:37 /artists/skypearls/ USER AGENT (Mozilla/5.0 (compatible; Baiduspider/2.0; +http://www.baidu.com/search/spider.html)) rejected. Not Caching

    or

    13:02:10 /artists/zentoy/robots.txt USER AGENT (Mozilla/5.0 (compatible; Ezooms/1.0; ezooms.bot@gmail.com)) rejected. Not Caching

    Why doesn't it work anymore?
    And also the same data about Get or feed detected:

    12:56:32 /?/the-virgin-dolls/ Supercache disabled: GET or feed detected or disabled by config.

    Should I enable the option "Don’t cache pages with GET parameters. (?x=y at the end of a url)"?

    For the info, my website is multilingual (thanks to WPML). Could this be linked with the GET parameter? I use a permalink and sub-domains structure with no GET parameters. I'm confused...

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    WPML might be it but I don't know. I'd dump $_GET to a file using error_log() to see what it contains.

  7. RainbowMode
    Member
    Posted 2 years ago #

    Ok, I'll give it a try...
    But why the new warning data about the user agents?
    And why the preload cache process was (and is still) stuck after 88 pages?
    Should I cancel it and restart a new one?
    Can I make a new cache test when the preload mode is active?
    Thanks again for your help.

  8. RainbowMode
    Member
    Posted 2 years ago #

    After one hour letting the preload mode operate, I wanted to know if more pages were cached and regenerated the cache stats.
    The 88 cached pages are gone... 0 cached pages and 0 expired pages!
    I don't find any info in the debug file...
    Still warning data about user agents, and "Supercache caching disabled. Only using wp-cache. Non empty GET request", plus almost all the output data linked to the wp-admin section... why?
    I don't understand. It seemed to work, and without any reason the process stopped.
    Do you know if there's a solution to fix this?
    your help is still more than welcome...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic