WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Pages cannot be dispayed -Timestamps & Cache issue? (4 posts)

  1. RainbowMode
    Member
    Posted 1 year ago #

    Hi,

    I have a serious issue when I try to see my frontend site. There's a systematic warning message telling that the pages can't be displayed.

    If I refresh the urls, the pages are then correctly displayed.

    I then made a cache test and had a timestamps warning message:

    Test your cached website by clicking the test button below.

    Fetching http://www.rainbowmode.com/ to prime cache: OK
    Fetching first copy of http://www.rainbowmode.com/: OK (1.html)

    Fetching second copy of http://www.rainbowmode.com/: OK (2.html)

    The pages do not match! Timestamps differ or were not found!

    Things you can do:

    1.Load your homepage in a logged out browser, check the timestamp at the end of the html source. Load the page again and compare the timestamp. Caching is working if the timestamps match.
    2.Enable logging on the Debug page here. That should help you track down the problem.
    3.You should check Page 1 and Page 2 above for errors. Your local server configuration may not allow your website to access itself.

    I followed the above instructions.

    1. The timestamps is the same when I reload the page in a logged out browser.
    2. I enabled the debug page and if I understand the error log correctly,it seems that WP Super Cache is not enabled, but I guess the settings are nevertheless correctly set...

    For example:

    09:17:56 / No wp-cache file exists. Must generate a new one.
    09:17:58 / In WP Cache Phase 2
    09:17:58 / Setting up WordPress actions
    09:17:58 / USER AGENT (WordPress/3.4.1; http://www.rainbowmode.com) rejected. Not Caching
    09:18:01 / supercache dir: /homez.547/rainbowm/www/wp-content/cache/supercache/www.rainbowmode.com/
    09:18:01 / No wp-cache file exists. Must generate a new one.
    09:18:02 / In WP Cache Phase 2
    09:18:02 / Setting up WordPress actions
    09:18:02 / USER AGENT (WordPress/3.4.1; http://www.rainbowmode.com) rejected. Not Caching
    09:18:06 / supercache dir: /homez.547/rainbowm/www/wp-content/cache/supercache/www.rainbowmode.com/
    09:18:06 / No wp-cache file exists. Must generate a new one.
    09:18:07 / In WP Cache Phase 2
    09:18:07 / Setting up WordPress actions
    09:18:07 / USER AGENT (WordPress/3.4.1; http://www.rainbowmode.com) rejected. Not Caching

    or

    09:40:05 /artists/revides/ supercache dir: /homez.547/rainbowm/www/wp-content/cache/supercache/www.rainbowmode.com/artists/revides/
    09:40:05 /artists/revides/ Cookie detected: wordpress_logged_in_a6b4a61ec0ee6f6d25b6ab7a51911ab2
    09:40:05 /artists/revides/ No wp-cache file exists. Must generate a new one.
    09:40:06 /artists/revides/ Cookie detected: wordpress_logged_in_a6b4a61ec0ee6f6d25b6ab7a51911ab2
    09:40:06 /artists/revides/ In WP Cache Phase 2
    09:40:06 /artists/revides/ Setting up WordPress actions
    09:40:06 /artists/revides/ Created output buffer
    09:40:06 /artists/revides/ Cookie detected: wordpress_logged_in_a6b4a61ec0ee6f6d25b6ab7a51911ab2
    09:40:09 /artists/revides/ Output buffer callback
    09:40:09 /artists/revides/ Supercache disabled: GET or feed detected or disabled by config.
    09:40:09 /artists/revides/ Cookie detected: wordpress_logged_in_a6b4a61ec0ee6f6d25b6ab7a51911ab2
    09:40:09 /artists/revides/ Not caching for known user.
    09:40:09 /artists/revides/ Cache is not enabled. Sending buffer to browser.
    09:40:09 /artists/revides/ wp_cache_shutdown_callback: collecting meta data.
    09:40:09 /artists/revides/ Did not write meta file: wp-cache-6532144f2d1bbe26e4b40de45386f8e5.meta ** *1* *1*
    09:40:11 /artists/revides/index.php?wpsc_ajax_action=get_cart Cookie detected: wordpress_logged_in_a6b4a61ec0ee6f6d25b6ab7a51911ab2
    09:40:11 /artists/revides/index.php?wpsc_ajax_action=get_cart In WP Cache Phase 2
    09:40:11 /artists/revides/index.php?wpsc_ajax_action=get_cart Setting up WordPress actions
    09:40:11 /artists/revides/index.php?wpsc_ajax_action=get_cart Not caching POST request.

    3. I don't see any error on Page 1 & 2.

    This is extremely problematic because the all website seems to be offline if I don't refresh every link to generate a cached file, and I'm not sure anyone else will do this but will leave the site instead...

    Is the issue linked with the timestamps? Am I doing something wrong?
    I have no idea how to fix this regarding the procedure I followed.

    I'll try to preload the pages once again, but I don't know what else I can do, and I can't afford to have the site "offline".

    Any help is really welcome...
    Thanks forward!

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. RainbowMode
    Member
    Posted 1 year ago #

    This is a complete nightmare...
    Even with the development version and the timestamps issue fixed, the website seems still to be offline ("page cannot be displayed" message) if I don't refresh the urls.
    Your help is still appreciated and welcome, but so far I have no other solution than deactivating the plugin.
    Thanks forward to let me know if there's a way to fix this...

  3. RainbowMode
    Member
    Posted 1 year ago #

    I found an alternative...

    The warning message "page cannot be displayed" is more explicit if I use Firefox, and could maybe help to fix the issue, or at least now I know that the problem seems directly linked with the method of caching.

    Firefox is telling me this (in french):
    "Erreur d'encodage de contenu
    La page que vous essayez de voir ne peut ĂȘtre affichĂ©e car elle utilise un type de compression invalide ou non pris en charge."

    If I translate it:
    "Encoding content error.
    The page you try to see cannot be displayed because it uses an invalid or not supported compression type."

    Does this message help to locate the issue?
    Why does the cache process work for some pages and not for others?

    Meanwhile... If I manually refresh the url of the page after this warning message, it's then correctly displayed and cached.

    So... I will control all the pages and follow that temporary procedure. But it's really not a final solution...

    Any idea why this is happening and how to fix it?
    Thanks again for your help!

  4. RainbowMode
    Member
    Posted 1 year ago #

    Hi,

    I started a new prelod cache for a new test, but at the end, even if I had received a WordPress message telling me that the cache preload was completed, It seems that the pages were not really cached, I had to manually cache almost all of the (more than 500) pages of the site.

    After this new test, when I'm loading a page, the warning message is still the same: "page cannot be displayed" with IE and "Encoding content error..." with Firefox.

    If I refresh the url, the page is then again correctly cached.

    Am I the only one facing this problem?
    Your help is still more than welcome...
    Thanks forward!

    [ Please do not bump, that's not permitted here. ]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic