WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
OSSDL CDN off-linker not working from Super Cache (6 posts)

  1. catnhat
    Member
    Posted 3 years ago #

    Prior to my recent switch to Super Cache, I have already been using "OSSDL CDN off-linker" plugin for several months.

    Once I saw it was included in Super Cache plus the ability to do multiple CNAMES, I decided to make the move.

    However, it doesn't work from my super cache at all. I have tried the following and it won't work from super cache:

    • Uninstall OSSDL and use super cache CDN enabled
    • uninstall both OSSDL and Super Cache, Reinstall just super Cache

    I have alot of static images, so I have resorted back to the original OSSDL plugin.

    Is there a migration step I may have missed?

    Thanks

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Weird, your post has somehow modified the html of this page. I've marked this thread modlook so it can be edited.

    The plugin included in Supercache uses the same configuration options so it should work. Maybe debug it manually yourself?

  3. Fixed the layout.

    PLEASE don't use li tags without a wrapping UL or OL around 'em ;) It ganks layout.

  4. catnhat
    Member
    Posted 3 years ago #

    I just reinstalled OSSDL and will run it from there.

  5. Backie
    Member
    Posted 3 years ago #

    I changed line 126 to

    update_option('ossdl_off_cdn_url', (bool)$_POST['ossdl_off_cdn_url']);

    and fixed the issue for me.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Backie - that won't work for anyone who wants to use the included cdn functionality. I've added a check to make sure the CDN url is non-blank before rewriting so at least you should be able to set it blank to disable it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic