WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
option to turn off debug messages (3 posts)

  1. thomask
    Member
    Posted 1 year ago #

    My client got some special old software which reads one special rss channel. Problem is, that when the rss contains a comment, the software throws error. And wp-super-cache adds
    <!-- Cached page generated by WP-Super-Cache on $timestamp --> and
    \n<!-- Dynamic page generated in $duration seconds. -->\n
    at the and of the page

    i had to edit wp-cache-phase2.php and delete those comments, but it is against easy upgradability and i do not know if it would not broke something as you are testing
    preg_match( '/(Cached page generated by WP-Super-Cache on) ([0-9]*-[0-9]*-[0-9]* [0-9]*:[0-9]*:[0-9]*)/' for something on wp-cache.php

    so plese could you add option to turn the message off or tell me if there is some filter at the end of caching, so i can filter the result and delete those notices.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    You're not the first to have this problem. I'll add this to the TODO list.

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    I forgot this was already in. Grab the dev version and install it. Go to the Debug settings page and you can turn off "Cache Status Messages" there.

    http://ocaoimh.ie/y/2o

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic