WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Only Dynamic pages are served. (8 posts)

  1. pashaweb
    Member
    Posted 5 years ago #

    Hi

    I've following plugin instructions to install the plugin. However I only see Dynamic Page Served, never Cached. When I check wp-content/cache/supercache folder I see the domain name and index.html files, but when accessing that post on the blog it never shows as Cached, always Dynamic.

    Please advise.

    The plugin seems to be working:

    WP-Cache
    * 15 cached pages
    * 0 expired pages
    WP-Super-Cache
    * 101 cached pages
    * 0 expired pages

  2. beisbolct
    Member
    Posted 5 years ago #

    I am having that same issue as well.

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Do you have the correct lines in your .htaccess file?

    Also, I believe he removed the "cache" indicator at the bottom of the resulting cache files, for some reason.

  4. beisbolct
    Member
    Posted 5 years ago #

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    
    RewriteCond %{REQUEST_URI} !^.*[^/]$
    RewriteCond %{REQUEST_URI} !^.*//.*$
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    # END WPSuperCache

    This is exactly what I have in the file.

    and this is what I see

    <!-- Dynamic Page Served (once) in 0.907 seconds -->

    Then a few minutes later

    <!-- Dynamic Page Served (once) in 0.858 seconds -->

    and this is what I get when i go to a different browser with cookies cleared. I know this is normal.

    <!-- Dynamic Page Served (once) in 0.824 seconds -->
    <!-- Cached page served by WP-Super-Cache -->
    <!-- Compression = gzip -->

  5. Rage00001
    Member
    Posted 5 years ago #

    I have the exact same problem as pashaweb, and exactly the same code inside .htaccess as beisbolct shown above.

    I just get <!-- Dynamic Page Served (once) in XXXX seconds -->

    I have tried different browsers, even different computers, no cashed files are served, just stored correctly.

    I can confirm that files are being cached, both in admin and looking in the cache folder.

    I have also tried to enable Compression = gzip wich also did not work. I didn't get any errors or something, it just don't show anything...

    You find my site here: http://litt.sinna.no

    Please help :)

  6. Rage00001
    Member
    Posted 5 years ago #

    Just an update here...

    My frontpage (index) is caching as i should ??

    <!-- Dynamic Page Served (once) in 1.401 seconds -->
    <!-- super cache -->

    But i don't get this message in any article...

  7. Rage00001
    Member
    Posted 5 years ago #

    Another update guys....

    I tried another code inside the .htaccess file and now and got another result for the front page (index.php)

    Now i get this text:

    <!-- Dynamic Page Served (once) in 1.401 seconds -->
    <!-- Cached page served by WP-Super-Cache -->
    <!-- Compression = gzip -->

    I do get this message when displaying tags also...

    No changes in any article, still just dynamic message

    The differense is that the original is useing {REQUEST_URI} and this one is using {QUERY_STRING}

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*p=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{QUERY_STRING} !.*wp-subscription-manager=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz [L]
    
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} !.*s=.*
    RewriteCond %{QUERY_STRING} !.*p=.*
    RewriteCond %{QUERY_STRING} !.*attachment_id=.*
    RewriteCond %{QUERY_STRING} !.*wp-subscription-manager=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html [L]
    </IfModule>
    # END WPSuperCache
  8. recetasdepostres
    Member
    Posted 5 years ago #

    any updates on this at all? Thanks in advance! My blog is http://www.recetasdepostres.org

Topic Closed

This topic has been closed to new replies.

About this Topic