WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Not working after WP 3.3. Update (13 posts)

  1. hornedry2k
    Member
    Posted 2 years ago #

    After the Update caching is not possible. Caching is not working and delete the Cache is not possible, too.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    This works for me. Can you use the debug system in the plugin and try clearing the cache? It may report why it's not working.

  3. hornedry2k
    Member
    Posted 2 years ago #

    11:53:18 /wp-cron.php?doing_wp_cron=1323863597 In WP Cache Phase 2
    11:53:18 /wp-cron.php?doing_wp_cron=1323863597 Setting up WordPress actions
    11:53:18 /wp-cron.php?doing_wp_cron=1323863597 Not caching POST request.
    11:53:19 /wp-cron.php?doing_wp_cron=1323863597 Cache garbage collection.
    11:53:19 /wp-cron.php?doing_wp_cron=1323863597 Cleaning expired cache files in /var/www/web1/html/Blog/wp-content/cache/
    11:53:19 /wp-cron.php?doing_wp_cron=1323863597 Doing GC on supercache dir: /var/www/web1/html/Blog/wp-content/cache/supercache
    11:53:19 /wp-cron.php?doing_wp_cron=1323863597 Cache Expiry cron job failed. Probably mutex locked.
    11:53:19 /wp-cron.php?doing_wp_cron=1323863597 scheduled wp_cache_gc for 10 seconds time.

    Dont know if this is important but dont work.

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Do you have coarse file locking on the Advanced Settings page enabled? I think that's stopping it working. Disable it if it's on.

  5. brohism
    Member
    Posted 2 years ago #

    I also am not able to run Preload on my site following the 3.3 update. I do not have coarse file lock turned on.

  6. Djib's
    Member
    Posted 2 years ago #

    I have the same porblem.
    Caching is not working and delete the Cache is not possible, too.

    When I activate the debug mode on wordpress, there are two errors for this plugin (on my two sites):

    Notice: Undefined index: HTTPS in /homepages/33/d353440738/htdocs/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 526

    Notice: Undefined index: HTTP_X_FORWARDED_PROTO in /homepages/33/d353440738/htdocs/wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 526

  7. hornedry2k
    Member
    Posted 2 years ago #

    Hope they will fix it or i will use other Cache Plugin.

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    hornedry2k - "they" is only me unfortunately. You never answered my question about the coarse file locking.

    All of you, try the development version on this page. That may fix the problem for you.

  9. hornedry2k
    Member
    Posted 2 years ago #

    Its not working.... :(

    Cant delete the Cache.. i think i will use the other Cache Plugin. This here is dead i think.

  10. Jeremy Clarke
    Member
    Posted 2 years ago #

    Just so there's another person here to point it out, hornedry2k is being absurd. This plugin is not dead and the solo developer himself is in this thread trying to help you debug. He asked you to try disabling coarse file locking. You need to reply stating specifically if you tried that and if it worked for him to know if that was the problem or not. He also recommend you try the development version, so you should reply about whether that fixes your problem too before declaring that the plugin is dead.

  11. Iwasawafag
    Member
    Posted 2 years ago #

    Hi.

    I have the same notices, as Djib's in admin pages when I trying to enable filter by is_feed() from advanced_options page

    With disabled filter by page types I have no error displaying in admin page, but in blog and in /feed/ pages I can see next notices in debug mode

    Notice: Undefined index: HTTPS in /wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 526

    Notice: Undefined index: HTTP_X_FORWARDED_PROTO in /wp-content/plugins/wp-super-cache/wp-cache-phase1.php on line 526

    Warning: Cannot modify header information - headers already sent by (output started at /wp-content/plugins/wp-super-cache/wp-cache-phase1.php:526) in /wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 76

  12. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Iwasawafag - they're harmless warnings but fixed in the dev version.

    http://downloads.wordpress.org/plugin/wp-super-cache.zip

  13. Iwasawafag
    Member
    Posted 2 years ago #

    Oh, thank you. You responding so quickly, that's great

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic