WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] Not all pages are returned cached (8 posts)

  1. Freedomuser
    Member
    Posted 5 years ago #

    Interesting results...

    http://sidestreets.freedomblogging.com/
    <!-- Dynamic Page Served (once) in 0.343 seconds -->
    <!-- super cache gz -->

    http://thepulpit.freedomblogging.com/
    <!-- Dynamic Page Served (once) in 0.182 seconds -->
    <!-- super cache gz -->

    http://gazetteafasports.freedomblogging.com/
    <!-- Dynamic Page Served (once) in 0.276 seconds -->

    http://ocvarsity.freedomblogging.com/
    <!-- Dynamic Page Served (once) in 1.807 seconds -->

    None of the posts are returning cached.

    Any ideas?

  2. webmaestro
    Member
    Posted 5 years ago #

    I noticed more strangeness on a couple of other freedomblogging.com blogs:

    http://gazettenewsroom.freedomblogging.com/

    <!-- Dynamic Page Served (once) in 0.207 seconds -->
    <!-- super cache -->

    http://gazetteafasports.freedomblogging.com/

    <!-- Dynamic Page Served (once) in 0.276 seconds -->

    The links from Freedomuser, in addition to those from my colleague Freedomuser, have the same *exact* settings in WP Super Cache, yet there are 3 different Cache msgs.

    Gzip is OFF. Gzip was ON three hours before Freedomuser did his tests, but it was turned OFF to determine if it would have an effect.

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    That's really odd. Have you checked if there's a supercache file for those broken blogs in wp-content/cache/supercache/hostname/ ?

  4. beisbolct
    Member
    Posted 5 years ago #

    On my site http://soxanddawgs.com

    None of the files are getting cached at all using plugin. One thing I realized is that I had the default permalink structure. Would that be the cause of the posts not getting cached?

  5. webmaestro
    Member
    Posted 5 years ago #

    @Donncha: Short answer is 'Yes'.

    There's more info here on this other post about steps to use httpd virtual conf files instead of .htaccess, including a bunch of info about what's in my wp-content, cache, supercache all the way down the path: /path/to/wordpress-mu-X.Y.Z/wp-content/cache/supercache/clay.freedomblogging.com/2008/09/11.

  6. webmaestro
    Member
    Posted 5 years ago #

    BTW, I haven't seen anything in the LOGs...

  7. beisbolct
    Member
    Posted 5 years ago #

    Apparently my problem has been fixed by making the sure the permalinks were the fancy ones and not the default as the plugin is now caching pages like crazy.

  8. webmaestro
    Member
    Posted 5 years ago #

    It looks like the issue was in the Apache Directives. See this post on using httpd virtual conf files instead of .htaccess files for more details.

    Thank you for your help!

Topic Closed

This topic has been closed to new replies.

About this Topic