WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] No WP-Super-Cache pages created / "Use mod_rewrite to serve cache file (6 posts)

  1. daniel.vos
    Member
    Posted 1 year ago #

    Good morning,

    I am experiencing a bizarre problem. I have enabled super-caching, but no WP Super Cache pages are being created.

    Settings

    WP Super Cache 1.2 is installed and the following settings are enabled:

    • "Caching On"
    • "Cache hits to this website for quick access"
    • "Use mod_rewrite to serve cache files"
    • "Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated."
    • "Mobile device support."

    Stats

    However, when I look at the Cache Contents stats, WP-Super-Cache shows 0 cached pages but lots of WP-Cache pages (at the moment: 122 cached page, 21 expired pages). Anytime I click the "regenerate cache stats" link, WP-Super-Cache always shows "0 cached pages," even though the numbers for WP-Cache are always changing.

    FTP

    Digging a little deeper, if I look at the folder structure via FTP, I can see a folder called /wp-content/cache/supercache When I inspect the supercache folder, there are folder names which correspond to the article names on my website, and new folders are being added all the time as users visit the site.

    BUT... all of the supercache folders are empty!

    Debugging

    When I turn on Debugging and look at the debug log, I see the following message for roughly 80% of hits on the website: "Supercache disabled: GET or feed detected or disabled by config."

    Where do I go from here?

    My question for the community is this: What does this message mean? It looks like it means that supercache is disabled because of one of three possible reasons:

    1. GET
    2. Feed detected
    3. Disabled by config

    What do each of these things mean? How do I figure out which one of these three things is causing supercache to be disabled? And how do I fix the problem?

    Thanks for your help!

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have any parameters added to the URLs of your blog? They're GET parameters, like:
    http://example.com/?blah=1

    "blah=1" are the bits you want to look for.

    Are you using a proxy server or something other than plain mod_php and Apache? Sometimes those parameters are added by them.

  3. Martin
    Member
    Posted 1 year ago #

    I'm getting esxactly the same.
    I'm using PHP mode and nothing is being added to the URLs which use a permalink structure of /%postname%

    Site is http://www.geekandjock.com though I'm unsure whether you can tell anything.

    Thoughts?

  4. Martin
    Member
    Posted 1 year ago #

    OK, you wouldn't happen to be using the AddThis Social plugin, would you?

    I just found this - http://wordpress.org/support/topic/wp-super-cache-issue-when-addthis-24x-is-active - made the code changes and supercache files are now being generated, as expected. Yippee!

  5. daniel.vos
    Member
    Posted 1 year ago #

    Hi Martin,

    Yes, as a matter of fact I am using the AddThis Social plugin. All of the posts use the "post name" permalink structure, as well.

    I'm going to look into the WP Super Cache / AddThis issue further and report back later.

  6. daniel.vos
    Member
    Posted 1 year ago #

    Thanks for your help, Donncha and Martin. I applied the code changes recommended for AddThis (see http://wordpress.org/support/topic/wp-super-cache-issue-when-addthis-24x-is-active) and supercache files immediately started working again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic