WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] No cache for certain clients (8 posts)

  1. Måns Jonasson
    Member
    Posted 3 years ago #

    Hello,

    I've got a strange issue - when I access my site (WP Super Cache half on) with Firefox for OS X, the site returns cached pages. But when I use Google Chrome the site returns live pages every time.

    Is there something wrong here, or do certain clients just not "get" the cached contents?

    Also - I am using "half on" since I have a couple of hacks using GET queries to load posts inside pages (/url/to/page?post-name-slug) and it appears that with WP Super Cache fully on, something is screwed up and the posts are never loaded, i.e. the GET query is never passed on to the page. Is there a way around this?

  2. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Are you logged in on Chrome? Do you have the "Do not cache for known users" option checked?

    Try the debug system to see what the plugin does.

  3. Måns Jonasson
    Member
    Posted 3 years ago #

    No, I am not logged in, but the debug says the following:

    11:38:08 / Cookie detected: wordpress_test_cookie
    11:38:08 / Not caching for known user.

    I guess this means that since I once WAS logged in, WP remembers me and WP Super Cache still ignores caching for me?

  4. Måns Jonasson
    Member
    Posted 3 years ago #

    As for the queried versions of the pages, the debug tells me nothing, so I assume that the GET query is completely ignored by the mod_rewrite rules matching me against content in the /supercache/ directory?

  5. Donncha O Caoimh
    Member
    Posted 3 years ago #

    That cookie is probably it.

    The plugin won't serve a supercached page on urls with GET queries. They should be cached as half-on files.

  6. Måns Jonasson
    Member
    Posted 3 years ago #

    Thank you,

    my problem is that with Supercache "on" (instead of half on) the pages with queries are all served the same supercache file, regardless of the query.

    With "half on" mode it works, but I would love to be able to enable full caching.

    Are you saying that this SHOULD work in supercache mode? That pages with GET queries should be getting half-on cached files? Because they are not, in my case. It is like WP Super Cache is just ignoring the queries altogether, and serving the supercached copy of the page w/o query.

  7. Donncha O Caoimh
    Member
    Posted 3 years ago #

    Yeah, check your .htaccess rules. There should be a line in there checking on REQUEST_URI. That variable is set when GET parameters are used and stops supercache files getting served.

    Half on mode is just as fast as full supercaching, mostly so just use that if the problem persists.

  8. Måns Jonasson
    Member
    Posted 3 years ago #

    Alright, I will stick with half on then, if there is no discernable punishment for not going "full-on" super cache.

    Thanks a lot for all your answers!

Topic Closed

This topic has been closed to new replies.

About this Topic