WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] New Installation not caching (5 posts)

  1. appleo
    Member
    Posted 6 years ago #

    This is a previously installed and working WP 2.5 site, now with Super Cache 0.6.6. The configuration is all defaults. I have used this plugin before and it installed and just "worked". But on this installation there is no caching at all. The WP-Super-cache was "enabled", the ROOT htaccess was updated, the wp-content/cache directories were created (but no cache files are being created), wp-cache-config.php is writable, there are no errors in the Apache error_log, no evidence of comments being embedded in the HTML source, and no errors showing in the Admin. No nothing.

    Thanks for any help on where to start looking!

    This is after about an hour of traffic:

    $ find wp-content/cache -ls
    8110416    4 drwxr-xr-x   3 apache   apache       4096 Aug  4 10:45 wp-content/cache
    8110514    4 -rw-r--r--   1 apache   apache         81 Aug  4 10:45 wp-content/cache/.htaccess
    8110513    4 drwxr-xr-x   2 apache   apache       4096 Aug  4 10:42 wp-content/cache/meta
  2. appleo
    Member
    Posted 6 years ago #

    Problem WAS: define( 'WP_CACHE', true ); was below wp-settings.php.

  3. mwilbers
    Member
    Posted 6 years ago #

    Hello appleo,
    Got the same problem here, but don't know exactly what you mean with your solution...

    Would be grateful if you could explain

  4. appleo
    Member
    Posted 6 years ago #

    I found the answer in readme.txt. The WP_CACHE setting has to be defined in wp-config.php, and must come before the line with wp-settings.php. That did it for me. I had several permissions related errors before that, but they well reported in the Admin, so it was obvious what to fix.

  5. mwilbers
    Member
    Posted 6 years ago #

    Thanx appleo. But unfortunately it did not do the trick for me, as these settings are in the correct location in my wp-config.php, all the way on top of all the rest.

    Guess I have to look a bit further.

    Strange though, as the previous versions worked without a problem.

Topic Closed

This topic has been closed to new replies.

About this Topic