WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] New htaccess rules in 0.8.9 may require Apache config change (2 posts)

  1. Kelson
    Member
    Posted 5 years ago #

    I ran into a problem when updating WP-Super Cache to version 0.8.9. I have two blogs on the same server, updated the plugin on both, and subsequently saw a massive drop-off in traffic on one site.

    I discovered that it was actually showing a 500 server error on that site, but the other one remained typical. I checked both blogs, but they looked fine as far as I could tell. A little investigation turned up "ExpiresActive not allowed here" in the Apache error log. It was the new .htaccess file in wp-content/cache. The reason I hadn't seen the error myself was that I was logged in, so it wasn't trying to load from the cache.

    The two sites had different AllowOverride permissions in the Apache config. One had "AllowOverride All", and was perfectly happy. The other had "AllowOverride FileInfo Options", which isn't enough for ExpiresActive.

    I added Indexes to the AllowOverride line, and now the site seems to be back to normal. I figured I'd post the problem and solution in case anyone else ran into it when upgrading the plugin.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Just to set other minds at ease. Those rules have been in the plugin for quite a while, and the correct AllowOverride is listed in the readme.txt in the Installation section.

    Glad you upgraded though, and I think you'll appreciate the next version too because it reduces the number of cache file significantly!

Topic Closed

This topic has been closed to new replies.

About this Topic