WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Multi-Site: Caching sites where plugin's disabled (7 posts)

  1. Curtiss Grymala
    Member
    Posted 3 years ago #

    While using the WP Super Cache plug-in, I've found that it seems to activate itself on the entire multi-site network, even when you only enable it for specific sites within that network.

    == WP Super Cache Version ==
    0.9.9.6

    == WordPress Version ==
    3.0.1

    == Steps to Reproduce Error ==

    1. Install WP Super Cache on a WordPress multi-site installation
    2. Activate the plug-in for a single site within the multi-site installation
    3. Go to the backend of a site within the multi-site network on which you have not enabled the plug-in.
    4. Modify a page or post in that site
    5. Visit the page with your browser and view the source of the page

    == Description of Error ==
    At the very bottom of the page source, you will see something similar to:

    `<!-- Dynamic page generated in 1.044 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2010-11-15 12:14:00 -->`

    == Current Solution ==
    In order to stop the pages from being cached by the WP Super Cache plug-in, I have to activate the plug-in on that site, then disable it within its "Settings" page.

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Unfortunately the plugin is all or nothing. If you wanted to enable it specifically on one or two blogs then you could write a plugin to check the $wpdb->blogid and set DONOTCACHEPAGE to stop it caching when not required.

  3. Curtiss Grymala
    Member
    Posted 3 years ago #

    Thanks for the info, donncha. Now that I know how it works, I know how to deal with it.

  4. Jazzvox
    Member
    Posted 3 years ago #

    After upgrading in WP 3.0 1 using Multisite / Domainmapping the SuperCache link in Backend settings menu is gone. In the Plugins view clicking on the settings link gives me an error: 1a-sales.com/wp-admin/options-general.php?page=wpsupercache. Anything wrong with my WordPress?

  5. Jazzvox
    Member
    Posted 3 years ago #

    P.S.: wp_supercache is activated global

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    It should be under the Superadmin menu now. I'll have to update the plugins link.

  7. Jazzvox
    Member
    Posted 3 years ago #

    Yep, it is and has been before.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic