WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Mod Rewrite rules cannot be updated! (5 posts)

  1. Mitch
    Member
    Posted 3 years ago #

    I keep getting this Mod Rewrite rules cannot be updated! with the latest 0.9.9.6

    I tried everything in the read me even uninstalled and re-installed.
    Install is at http://www.phpbbmodinstalls.com/

    I even manually put in the rules and same error
    here is my htaccess file and it is named correctly .htaccess

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{HTTP_user_agent} !^(w3c\ |w3c-|acs-|alav|alca|amoi|audi|avan|benq|bird|blac|blaz|brew|cell|cldc|cmd-|dang|doco|eric|hipt|htc_|inno|ipaq|ipod|jigs|kddi|keji|leno|lg-c|lg-d|lg-g|lge-|lg/u|maui|maxo|midp|mits|mmef|mobi|mot-|moto|mwbp|nec-|newt|noki|palm|pana|pant|phil|play|port|prox|qwap|sage|sams|sany|sch-|sec-|send|seri|sgh-|shar|sie-|siem|smal|smar|sony|sph-|symb|t-mo|teli|tim-|tosh|tsm-|upg1|upsi|vk-v|voda|wap-|wapa|wapi|wapp|wapr|webc|winw|winw|xda\ |xda-).*
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html.gz" [L]
    
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress_logged_in|wp-postpass_).*$
    RewriteCond %{HTTP:X-Wap-Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP:Profile} !^[a-z0-9\"]+ [NC]
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{HTTP_user_agent} !^(w3c\ |w3c-|acs-|alav|alca|amoi|audi|avan|benq|bird|blac|blaz|brew|cell|cldc|cmd-|dang|doco|eric|hipt|htc_|inno|ipaq|ipod|jigs|kddi|keji|leno|lg-c|lg-d|lg-g|lge-|lg/u|maui|maxo|midp|mits|mmef|mobi|mot-|moto|mwbp|nec-|newt|noki|palm|pana|pant|phil|play|port|prox|qwap|sage|sams|sany|sch-|sec-|send|seri|sgh-|shar|sie-|siem|smal|smar|sony|sph-|symb|t-mo|teli|tim-|tosh|tsm-|upg1|upsi|vk-v|voda|wap-|wapa|wapi|wapp|wapr|webc|winw|winw|xda\ |xda-).*
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html -f
    RewriteRule ^(.*) "/wp-content/cache/supercache/%{HTTP_HOST}/$1/index.html" [L]
    </IfModule>
    
    # END WPSuperCache
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Weird. The only thing I can think of is to suggest opening wp-cache.php and trying to debug what's happening. Look for the text of the error message and follow the logic back.

    Is caching working?

  3. Mitch
    Member
    Posted 3 years ago #

    No Caching is not working.
    I will look into wp-cache.php now

  4. Mitch
    Member
    Posted 3 years ago #

    I tried debug and its not debugging. (not producing a debug file in cache directory)
    I also found that my .htaccess file is not writable and I don't know why
    The server is mine and I have no problem with any other account on the server.
    I tried to rewrite the permalink and it said htaccess is not writeable so, I guess I have to find out why its not rewritable first.
    As the governor of California Once said in his movies
    Be Back!

  5. Mitch
    Member
    Posted 3 years ago #

    OK Did a full wipe out everything!

    Reinstalled WordPress installed following plug-ins
    .html on PAGES - permalink set to /%postname%/ - (Had a html site) before.
    Contact Form 7
    Really Simple CAPTCHA
    WordPress Importer
    WP Super Cache

    Got this error after activation and clicking link to settings

    Warning: file(/home/xxxxxxx/public_html/wp-content/wp-cache-config.php) [function.file]: failed to open stream: No such file or directory in /home/xxxxxx/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 1569
    
    Warning: Invalid argument supplied for foreach() in /home/phpbbmod/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 1570
    
    Warning: Invalid argument supplied for foreach() in /home/xxxxxx/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 1590

    changed to mod rewrite and low and behold
    Mod Rewrite rules updated!
    then went to tester & Contents
    The timestamps on both pages match!

    I guess I'm back to normal.
    Thanks for a excellent plug in I use it on all my sites

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic