WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Memory Usage on server went up. Is this normal? (14 posts)

  1. sebastienpage
    Member
    Posted 3 years ago #

    Since I updated WPSC to version 0.9.9.4, the memory usage on my server went up by a good 50%. I haven't changed any settings, I just updated the plugin.

    Is this normal? Is there a bug in 0.9.9.4?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    When I updated, the cache actually got turned off. Might want to go recheck the settings, make sure you have it in mod_rewrite mode and such.

  3. sebastienpage
    Member
    Posted 3 years ago #

    Cache is on. It's going insane! Here is a picture that hsows the server load. You can clearly tell when I updated to WPSC's latest version: http://twitpic.com/2sbqyv. Note that my site hasn't seen any increase in traffic, neither did I install and changed anything on the site.

    And here are my settings:
    http://twitpic.com/2sbt9f/full
    http://twitpic.com/2sbthe/full

    The Preload Mode settings: http://twitpic.com/2sbtvi/full

    The Cache Tester gives me an error: http://twitpic.com/2sbtnh/full

    I set the debugger to send me emails but never received anything (also checked my spam folders and nothing there).

    To me, there truly is a problem with WP Super Cache and this problem appeared with the last update. It's making my site go up and down and it's pretty embarrassing, and stressful.

    Hopefully you guys can help me figure out what's going on.

    Thanks

    Sebastien

  4. Arpit
    Member
    Posted 3 years ago #

    Some suggestions:

    1) Uncheck "Compress pages.." option, it will increase your server's CPU usage by doing gzip on every cache page.
    2) Uncheck PreLoad mode.
    3) STOP all debugging.

    Above 3 points will definitely reduce CPU usage. It worked for me and CPU usage reduce to half after upgrade to 0.9.9.5.

    Hope this works for you.

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    arpitshah - compression is only done once per page, not per pageload on cached pages so that shouldn't be much of an issue, but worth trying just in case.

    sebastienpage - have you verified the mod_rewrite rules are still correct? The .4 release deleted the rules to clean things up going to PHP mode (or off) but I reverted that change in .5 again.

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    sebastienpage - try the development version on this page, just fixed a bug that might be the problem.

  7. sebastienpage
    Member
    Posted 3 years ago #

    dooncha - thanks for the help. I had already updated the .htaccess file with the new rules.

    I looked on the page you linked to and (I must be dumb), I cannot find any link to a development version. I am currently at .5 and this seems to be the latest I can get. Could you please let me know what I am missing?

    arpitshah - I will give it a try. Thanks for your tips!

  8. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Oh, never mind. Grab .5 again and reinstall it as I forgot to tag it on Friday so it's basically the development version. That's a bad thing to do of course but I'll fix that later.

  9. sebastienpage
    Member
    Posted 3 years ago #

    The link under "Current Version" returns a 404. The "Download version 0.9.9.5" link in the sidebar does work but I believe it is the version before the update you did earlier today. I'm sorry to be such a pain, but can you confirm? Thanks

  10. Arpit
    Member
    Posted 3 years ago #

    Sebastien - just uninstall and install plugin from admin panel and that should be new one. I do see latest changes in current available version.

  11. sebastienpage
    Member
    Posted 3 years ago #

    I tried to uninstall the plugin yesterday and it gave me an error message when I hit the "confirm" button. Strange. So I reactivated the plugin right away, turned it back on and saw options that I didn't have before. Very strange! For example the "Advanced" settings in the debug console were not there before.

    Additionally, the cache tester stopped giving me a timestamp error.

    At any rates. The site did better for the rest of the day and the memory usage didn't randomly go up as it used to do for the last few days.

    However, I still get 2 HUGE memory usage spikes at around midnight and 8am. These have happened everyday since I updated WPSC and I have no idea why. (here is a picture of memory usage http://twitpic.com/2su5wa/full).

    As usual, any insight would be much appreciated. Thank you in advance.

  12. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Those spikes are probably when your site starts preloading? I've added a 5 second delay between each preloaded post to reduce the load. Unfortunately it'll take longer to preload though.

  13. sebastienpage
    Member
    Posted 3 years ago #

    I updated to .6. Just got one of those HUGE spikes that actually take my blog down. I had to reboot the server to kill everything.

    Should I just turn preloading off? I have over 3,000 posts on my blog.

  14. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Try the development version. It could be wp-cron duplicating the preloads.

    Did you check your access logs? Did you verify it was preload traffic (You'll see your own IP address, and a WordPress client requesting lots of pages)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic