WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Maximum execution time on page update (4 posts)

  1. Marcel Brinkkemper
    Member
    Posted 1 year ago #

    When I update a page with many sub-pages, something breaks when wp super cache is activated. How to solve this (apart from increasing max execution time)?

    Maximum execution time of 30 seconds exceeded in /home/my_site/public_html/wp-content/plugins/wp-super-cache/wp-cache-phase2.php on line 724

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Martin
    Member
    Posted 1 year ago #

    Yeah, I noticed this today myself.
    Got a few 500 errors as well.

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    I think you have too many cached pages. That line is in the prune_super_cache() function that helps clear up cached files.

    You should probably run garbage collection more often and disable preload mode. Or increase max execution time unfortunately.

  4. Marcel Brinkkemper
    Member
    Posted 1 year ago #

    More garbage collection did the trick. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.