WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Locked into legacy caching (3 posts)

  1. sjspain
    Member
    Posted 1 year ago #

    Since installing WP Super Cache, I can only get it to create and serve legacy cache files (WP-Cache). I've tried using php caching and rewrite, but they are being ignored. I've never set it to use legacy in the advanced configuration.

    I had been using W3 Total Cache previous to replacing it with WP Super Cache, this may well be the source of the problem. I've had a good poke around and compared various files with another of my wordpress sites that has WP Super Cache working OK. Nothing makes any difference.

    Feel like I'm banging my head against a brick wall. Any suggestions.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. nekno
    Member
    Posted 1 year ago #

    I'm having the same problem on Apache with all three caching options (mod_rewrite, PHP, or legacy).

    When I turned on debugging, I was seeing the following error:

    Supercache disabled: GET or feed detected or disabled by config.

    Here's the full log for one page request, with {VALUES} substituted for sensitive info:

    03:08:06 {URL_PATH} supercache dir: /home/{SITE}/public_html/wp-content/cache/supercache/{DOMAIN}/2009/11/21/{PAGE_TITLE}/
    03:08:06 {URL_PATH} No wp-cache file exists. Must generate a new one.
    03:08:07 {URL_PATH} In WP Cache Phase 2
    03:08:07 {URL_PATH} Setting up WordPress actions
    03:08:07 {URL_PATH} Created output buffer
    03:08:07 {URL_PATH} Output buffer callback
    03:08:07 {URL_PATH} Supercache disabled: GET or feed detected or disabled by config.
    03:08:07 {URL_PATH} Gzipping buffer.
    03:08:07 {URL_PATH} Writing gzipped buffer to wp-cache cache file.
    03:08:07 {URL_PATH} Renamed temp wp-cache file to /home/{SITE}/public_html/wp-content/cache/wp-cache-6f35dec9cbf57b7afa633b87b5fee432.html
    03:08:07 {URL_PATH} Writing gzip content headers. Sending buffer to browser
    03:08:07 {URL_PATH} wp_cache_shutdown_callback: collecting meta data.

    There are three conditions that result in that error:

    1. The $_GET value is not empty.
    2. The request is for a feed, I assume an RSS feed.
    3. The supercache directory has ".disabled" appended to the end.

    So I edited my wp-cache-phase2.php file to break the code out into three different branches to detect which condition was causing the error message.

    For me, the problem is that the $_GET value is never empty, which I think means there's a query string in the URL. This is almost always going to be the case with traffic directed from emails and social networks, so it seems that it's simply not going to work.

    Furthermore, when I turn on mobile browser support and enable the WPtouch plugin support, it doesn't work with WPtouch. One of two things happens:

    1. The first browser to access a page creates the legacy cached file, and then all browsers after that receive the cached file. So if a mobile browser accesses a page first, the cached file is created with the WPtouch plugin theme, and all desktop browsers receive the WPtouch theme. The same thing happens if you access the page with a desktop browser first - all mobile browsers get the desktop theme instead of the WPtouch theme.
    2. Mobile browsers get the WPtouch theme and no cached file is created until a desktop browser accesses the page. Once the cached file is created by a desktop browser request, then mobile browsers receive the cached normal theme, and no longer get the WPtouch theme.
  3. sjspain
    Member
    Posted 1 year ago #

    Thanks nekno, you pointed me in the right direction. I took a look at the $_Get value and that led me to discover that the AddThis plug was causing the problem.

    Someone else had already spotted the problem here -
    http://wordpress.org/support/topic/wp-super-cache-issue-when-addthis-24x-is-active

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic