WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WP Super Cache] Load average is the same if ON or OFF (25 posts)

  1. eberdocarmo
    Member
    Posted 4 years ago #

    Hello,

    I would like to get some help, since I sent Donncha an email through his website but got no response.

    The point is that on my blog http://www.noticiasautomotivas.com.br (which has around 60.000 visitors per day), my load average is the same, with WP Super Cache activated or deactivated.

    My server is an Intel i7 860, with 8 GB of RAM, and the load average is always around 8.00.

    I talked to WiredTree support and they made all kinds of checks and improvements on the server, as regards Litespeed, PHP, MySQL and everything, but the load wont drop.

    If the load is always the same, it feels that WP Super Cache is not necessary, and is not gonna help in anyway.

    The pages are being cached, since if I enable it, within 60 minutes I get around 800 cached pages.

    Any hints as about what should I do to solve this?

    I know the plugins will be blamed for this. But until sometime ago, the load used to be 2.00, with exactly the same plugins....

    The list of all plugins currently installed:

    Akismet
    All in One SEO Pack
    Contact Form 7
    Evermore
    Google XML Sitemaps
    Headache With Pictures
    Health Check
    IntenseDebate
    Missed Scheduled
    PubSubHubbub
    Related Posts
    RSS Footer
    SEO Friendly Images
    WP-PageNavi
    WP-Polls
    WP File Cache
    WP Minify
    WP Super Cache

  2. eberdocarmo
    Member
    Posted 4 years ago #

    Anyone?

  3. Raghu77k
    Member
    Posted 4 years ago #

    1) What is your url structure?

    http://codex.wordpress.org/Using_Permalinks

    try to search keyword - 'not recommended' in above link.

    2) put code in footer:

    <?php echo get_num_queries(); ?> queries in <?php timer_stop(1); ?> seconds.

    to be continued....

  4. Raghu77k
    Member
    Posted 4 years ago #

    The above mentioned thing are steps to improve performance.

  5. Raghu77k
    Member
    Posted 4 years ago #

    Some Question:

    1) your total post count?
    2) your total page count?

  6. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Use the debug system in the plugin to check if the pages are being served from the cache or somehow being regenerated on each request.

  7. eberdocarmo
    Member
    Posted 4 years ago #

    Thanks for the help. Stop using %postname% on permalinks would be bad for SEO, I wouldnt wanna change that.

    I have put the code in the footer, and showed this:

    frontpage - 5 queries in 0,255 seconds.
    post page - 9 queries in 0,283 seconds.

    My total post count: 16.839.
    My total page count: zero.

    Right now, WP Super Cache page says there are 4.854 posts cached.

    Using the debug system came up with a 800 kb textfile, in a matter of 10 seconds.

    Here is the file: http://www.noticiasautomotivas.com.br/da17fa99d4dcc3a69aa5a0f64423a369.txt

    I have found that this troublesome avatar.gif file is from Intense Debate. This means that having Intense Debate on my blog will make caching impossible?

    Looked for "ob_start" on my plugins files (downloaded entire plugins folder and searched) found nothing.

  8. Donncha O Caoimh
    Member
    Posted 4 years ago #

    A .gif file wouldn't stop your site caching. That's just one url on there. Anyway, the logs didn't mention any other file.

    Increase the log level to 5 and limit it to your IP address. See for yourself if anything suspicious shows up. No need to post 800K of the same repeating text!

  9. eberdocarmo
    Member
    Posted 4 years ago #

    Did what you told. Generated a much smaller file:

    http://www.noticiasautomotivas.com.br/3d9efaa12d827e1fc5a02329e159a8d5.txt

  10. eberdocarmo
    Member
    Posted 4 years ago #

    So, what is the problem?

  11. Donncha O Caoimh
    Member
    Posted 4 years ago #

    I can't tell from that. You'll have to logout and clear the cookies from your browser.

  12. eberdocarmo
    Member
    Posted 4 years ago #

    And then debug again?

  13. eberdocarmo
    Member
    Posted 4 years ago #

    Here goes another file, logged out and cookies cleared:

    http://www.noticiasautomotivas.com.br/663ad5bc7a62c5138a19f1fd6491576b.txt

  14. Donncha O Caoimh
    Member
    Posted 4 years ago #

    No use either because you don't load any "proper urls". Load a blog post and check the log. Anything there? Try to figure it out for yourself! :)

  15. eberdocarmo
    Member
    Posted 4 years ago #

    Great. This WordPress support forum is just good for nothing, since people have to "figure out for themselves".

    Nice help, Donncha!

  16. eberdocarmo
    Member
    Posted 4 years ago #

    Please do everyone a favor.... dont waste your and other peoples times replying like that.... this just doesnt help at all.

  17. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Ok, good luck fixing your problem.

    That log file has English language warning messages that I spent a long time working on. If you can't be bothered reading it and helping yourself get a better understanding of the software running on your website you should hire someone to do so.

  18. eberdocarmo
    Member
    Posted 4 years ago #

    For those who might come to this page in the future (since it ranks 3rd in google for wp super cache and intense debate), I have installed a plugin that actually solved the problem, making the load come from 10.00 to 1.50:

    http://wordpress.org/extend/plugins/jquery-image-lazy-loading/

  19. Donncha O Caoimh
    Member
    Posted 4 years ago #

    So that avatar.gif was causing a pageload and probably a db request? Good catch, and that plugin looks really useful!

  20. eberdocarmo
    Member
    Posted 4 years ago #

    I think that the issue was that Intense Debate was not letting WP Super Cache cache the page.

    I have around 15 plugins, and leaving all of them enabled, except Intense Debate, produced a load average of 3.00 instead of 10.00.

    So, the problem was with Intense Debate. Somehow, that lazy loading plugin made it stop asking information from the database.

    Another thing I did was remove avatars from comments. Maybe it helped too.

  21. whatsthatbug.com
    Member
    Posted 4 years ago #

    So, can you use the lazy loading plugin in conjunction with WP-SuperCache? Or are you using it instead of?

  22. Donncha O Caoimh
    Member
    Posted 4 years ago #

    You can use it with Supercache. I installed it on inphotos.org, and it made the page noticeably snappier :)

  23. eberdocarmo
    Member
    Posted 4 years ago #

    I am using both along. WP Super Cache is still important in this whole "not using PHP" thing.... only Lazy Loading wouldnt drop the load so much.

  24. Donncha O Caoimh
    Member
    Posted 4 years ago #

    Oddly enough, looking at my stats the images load when the page loads, even the photos below the fold. Must have a look at that sometime.

  25. eberdocarmo
    Member
    Posted 4 years ago #

    I have noticed that. The lazy loading plugin must not be working properly... maybe the WP Minify plugin must be messing with the Javacript of it. But anyways, the result is wonderful for me.... decreasing the load average was everything I needed!

Topic Closed

This topic has been closed to new replies.

About this Topic