WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Junk / Garbled Text Pages (21 posts)

  1. Delete Me
    Member
    Posted 5 years ago #

    Has anyone noticed if your cached enabled WP blog sometimes showed completely garbled text instead of what it should be? This happened to me a few times, and I'm wondering if it was because I sometimes manually delete the cache within the admin page so I can inspect changes I've made to my theme. I stopped doing that and simply disable the plugin when I'm customizing my themes. So far the issue hasn't reoccured.

    Weird.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    I remember this came up before when the wrong character encoding was used. The plugin now defaults to using UTF-8 which works for most people. Have you changed the encoding in your options page?

  3. Delete Me
    Member
    Posted 5 years ago #

    I haven't changed anything when installing but lemme checkie....

    Nope, it's using UTF-8. =) I did have to import my WordPress posts and comments from an older 2.0 fork so I wonder if that might have been a factor. Other than that weird issue, the cache is working cleanly. I'll just avoid clearing the cache in the future to be safe. =D

  4. Delete Me
    Member
    Posted 5 years ago #

    This is turning out to be a more serious problem than I thought. My home page resulted in garbage text showing out of the blue, though I haven't touched anything in Super Cache for a few days. I wonder what's causing it? I was using a slightly older version though so I'm updating to 0.6.6 and flushed the cache again to see if that resolves the issue.

    Other than UTF-8, what else could cause a problem like this?

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    I occasionally had this issue until I disabled the gzip compression.

    Dunno why it happens, but that seems to fix it for my specific case.

  6. Delete Me
    Member
    Posted 5 years ago #

    Hmmm, that's interesting. I've been reading about gzip and it seems it's better to have it done server side than using a php script anyway. Maybe it might be best use htaccess for this, and then use Super Cache with gzip disabled and that might do the trick.

  7. Delete Me
    Member
    Posted 5 years ago #

    Well oddly enough my server doesn't have mod_gzip enabled. That sucky McSucketh. =P

  8. sharebrain
    Member
    Posted 5 years ago #

    This is a serious problem. Today i upgraded to wp 2.6.1. and wp super cache to the newest version.

    and after that i get Junk / Garbled Text Pages too ... deleted wp-super-cache and everyting is fine again. so i guess i must run my blog without a cache plug now ? :(

    damn ... what can it be.... my blog is UTF-8 encoded. hopefully someone finds a fix for that. :-(

  9. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Have you got mod_deflate installed? If so, try removing it and see if that makes a difference.

  10. Delete Me
    Member
    Posted 5 years ago #

    sharebrain: It's the Gzip that causes it, why I don't know. Just keep that disabled, and the rest of the cache should work fine.

    Though for my particular server, both Super Cache and Gzip is too resource intensive for some reason and actually adds to the load time of my site. My site went down during a massive StumbleUpon spike and only went up again when I disabled Super Cache. Yes, really. Just goes to show how server configuration can have a major impact on how well your plugins run.

    For the future, I intend to use the feature of Super Cache that allows me to cache only one page, which really is all I'd need it for anyway. :D

  11. Fakey
    Member
    Posted 5 years ago #

    I've found the solution: if your pages are encoded in UTF-8 with the BOM the grabled text shows up. If you encode the page in UTF-8 without the BOM the page is displayed correctly.

  12. Fakey
    Member
    Posted 5 years ago #

    Just to clarify on my last post: supercache was working fine with my UTF-8 with BOM files prior to wordpress 2.6.1.

    Is wordpress now using the php "header" function that it wasn't using before? If so then the BOM (byte order mark) will be written before the 'header' function can be called, thus throwing a wrench in the whole process.

    It's just a guess. I haven't studied the changes.

  13. Delete Me
    Member
    Posted 5 years ago #

    Where's this BOM showing up and can it be removed?

  14. Fakey
    Member
    Posted 5 years ago #

    The BOM is at the beginning of the file. (see http://unicode.org/faq/utf_bom.html#29 )

    Yes the BOM can be removed. If you're on Windows just use Notepad++ and click "Format > Convert to UTF-8 without BOM". Otherwise you'll have to open the file with a hex editor and remove the first three bytes (0xEF 0xBB 0xBF).

  15. Delete Me
    Member
    Posted 5 years ago #

    Which file would I need to change, the super cache file?

  16. Fakey
    Member
    Posted 5 years ago #

    Change the header template file. Also, you should check the other parts of the template to make sure they don't have BOMs. If they do they will further corrupt the output. (e.g. a BOM on the top of the footer template would actually be added near the bottom of the generated output.)

  17. sharebrain
    Member
    Posted 5 years ago #

    no BOM here and the output was f*****d up :(

  18. sharebrain
    Member
    Posted 5 years ago #

    i think the pages were broken after i edited my templates ... but not sure. maybe that can be a hint ?

  19. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Do you have mod_deflate installed? There's a fix in trunk to disable that extension because on some hosts it tries to compress already gzipped data.

  20. preppeller
    Member
    Posted 5 years ago #

    I too am seeing the garbled text intermittantly since upgrading to WP 2.6.1 and WP Super Cache 0.7.1, even with Super Cache only "Half On" - everything was perfect before that.

    Is the mod_deflate fix in for 0.7.1?

    Its a bummer that I have had to go back to WP Cache to get around this problem as Super Cache is WAY better!

  21. preppeller
    Member
    Posted 5 years ago #

    Hmm, I just looked at the change log and the mod_deflate fix is in 0.7.1.

    Is there any way of disabling Super Cache from gzipping the "half on" files just to avoid this problem for now?

Topic Closed

This topic has been closed to new replies.

About this Topic