WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] It's caching index.php (6 posts)

  1. Matt
    Member
    Posted 5 years ago #

    ... and index.php is listed under "Rejected URIs".

    Any thoughts?

    Settings:
    WP Super Cache Status: ON (WP Cache and Super Cache enabled)
    Compression enabled
    Garbage Once every 24 hours
    Rejected URIs: wp-.*.php, index.php
    etc

  2. Matt
    Member
    Posted 5 years ago #

    Hmmm it's doing it with the setting

    HALF ON (Super Cache Disabled, only legacy WP-Cache caching.)

    So it seems not to be triggered by Super Cache plugin.

    Anyone?

  3. blakekr
    Member
    Posted 5 years ago #

    I seem to having this problem too ... it's a disaster. Haven't figured it out.

  4. Matt
    Member
    Posted 5 years ago #

    Sorry, no updates from me.

    If you're having issues with it due to your changes not showing up with a page refresh during development, I suggest having a tab open to the plugin's settings and clicking Delete Cache after each change you make.

    Or doing that, then disabling until your dev session is done, then re-enabling.

  5. Matt
    Member
    Posted 5 years ago #

    I stumbled on the fix: remove index.php from the rejected URI list. Yes, you read that correctly.

    Truth is stranger than fiction.

  6. blakekr
    Member
    Posted 5 years ago #

    you're kidding ... I'll have to try that when I'm feeling really, really brave again. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic