WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] ... is writable. Please make it readonly after your page is generated as th (12 posts)

  1. marco-raaphorst
    Member
    Posted 4 years ago #

    I get the warning "...is writable. Please make it readonly after your page is generated as this is a security risk."

    that root-directory is on 755 and all files are on 644. what do I need to chance to solve this?

  2. Happyworker
    Member
    Posted 4 years ago #

    I'm wondering the same thing. Is my website really at risk if I don't change the root attributes to 444 or 644? This might look like a dumb questions but if I change it, will people still be able to post?

  3. DebNCgal
    Member
    Posted 4 years ago #

    I have the same warning, as well. This seems like a normal question to ask. I don't understand why there's no answer.

    Should the WP root directory default (755) indeed be changed, based on the warning in Super Cache? If so, what would be the recommended permissions, and are there any downsides to assigning a more restrictive permissions setting to the root directory?

  4. Donncha O Caoimh
    Member
    Posted 4 years ago #

    755 perms on a directory is fine. It's probably owned by the same owner as the webserver or PHP user, making them writeable.

    I consider it a security risk, but unfortunately many hosting companies do this to make it easier for their users to do admin duties.

  5. DebNCgal
    Member
    Posted 4 years ago #

    Thank you very much for your input, donncha. And thanks for a great plugin in WP Super Cache.

  6. peevee
    Member
    Posted 4 years ago #

    Hi
    I get similar warning and my settings are 750
    Is this okay?
    Thanx
    PV

  7. SueJ1
    Member
    Posted 4 years ago #

    I am also getting the same warning - also with the root directory set to 750. Could you advise if I should change it? Many thanks!

  8. SueJ1
    Member
    Posted 4 years ago #

    One more question - which I hope is not a completely foolish one. :)

    As Super-Cache continues to work dynamically in the background, should I disable it on occasions when I am doing an FTP backup of the complete site, then turn it on again after the file dowload is finished?

    Thanks in advance for your response. :)

  9. Donncha O Caoimh
    Member
    Posted 4 years ago #

    SueJ1 - Probably don't need to change it, and clearing the cache is definitely a good idea if you're backing up the site and can't exclude the cache directory.

  10. SueJ1
    Member
    Posted 4 years ago #

    Many thanks for your reply! :) I can exclude the cache directory if I am doing a manual FTP backup, but it's easier simply to download the whole site, so I'll definitely use your tip of clearing the cache first.

    I've also realised that when I need to make changes to the site and want to check the result of those changes, I need to clear the cache and turn off Super Cache - or the pages don't update with a browser refresh. :)

    Having said that, I'm very happy with how smoothly Super Cache has integrated into the five sites I manage - with no problems and no clashes with any of the various plugins installed.

    It already does seem to make load times faster for all five sites, which is great!

    Many thanks for your fast response. :)

    Cheers,
    Sue

  11. HAWKS ONLINE
    Member
    Posted 3 years ago #

    Okay people!!So, my WP Super Cache on the Directly Cached Files, it's saying that I need to make a certain link read only, right now its writable.

    I need step by step explanation on how to do this.Don't talk codes, I'm new to this thing.Thanks!!

  12. HAWKS ONLINE
    Member
    Posted 3 years ago #

    I got it!!!

    WP Super Cache – Direct Cached Files
    Go to your Cpanel Account, Select File Management under the Files tab, It will take you to the File manager. In the File manager, you’ll see all the files; just pick one that you want to change permission. Then, on the very top tabs you’ll see a key (Change permissions), Click on that key while the file you want to change permission is still selected. From there you’ll know what to do!!!
    After, changing permission to read only, update the configurations on your WP Super Cache Settings. Change the permission back to writable in order to activate the Feature of WP Super Cache. Open your blog to generate the page you want cached. After, the page has been generated. Go back to the Change Permissions of the file in File Manager using Cpanel back to read only. Finally, you are done!! Hope it works for you, as it did for me. Goodluck!!

Topic Closed

This topic has been closed to new replies.

About this Topic