WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Internet Explorer GZIP Download Error (4 posts)

  1. Rishi
    Member
    Posted 6 years ago #

    Hello all,
    My Super-Cache works, except when I enable the GZip compression. When I do, Internet Explorer 6 and 7 start asking me to download the webpage instead of opening it (like Safari and Firefox). I've consulted this website:
    However, after inserting the code, I'm still not getting it to work. In fact, after making the modifications on that site, Internet Explorer won't even load my blog (Firefox and Safari still do, though).

    Let me double check with you guys:

    Do I insert the following into the .htaccess file that's in wp-content/cache?

    <Location /wp-content/cache/supercache/>
    AddEncoding x-gzip .gz
    AddType text/html .gz
    </Location>

    And do I insert the following into my main .htaccess under public_html?

    <IfModule mod_rewrite.c>
    RewriteEngine On
    # this part handles browsers that accept gzip compression
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1index.html.gz -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1index.html.gz [L]
    #this part handles browsers that don't accept gzip compression
    RewriteCond %{HTTP_COOKIE} !^.*comment_author_.*$
    RewriteCond %{HTTP_COOKIE} !^.*wordpressuser.*$
    RewriteCond %{HTTP_COOKIE} !^.*wp-postpass_.*$
    RewriteCond %{DOCUMENT_ROOT}/wp-content/cache/supercache/%{HTTP_HOST}/$1index.html -f
    RewriteRule ^(.*) /wp-content/cache/supercache/%{HTTP_HOST}/$1index.html [L]
    # the original rules must follow the supercache rules
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    Please let me know if I overlooked something dumb. My main .htaccess (the one under public_html) also had some parameters for WordPress itself, but I left those untouched.

    My website is can be found here:

  2. Miejsca
    Member
    Posted 5 years ago #

    The same problem over here -- it works with Firefox and it does not with IE. In IE I get garbage when I turn the compression on :( PITTY!

    BTW I use litespeed and not apache. Maybe that is the problem?

  3. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Possibly, but it's more likely that IE just sucks.

    Just disable the gzip compression, that's my advice. IE can't cope with it.

    You can try sticking this into your main root .htaccess file:

    AddEncoding x-gzip .gz
    AddType text/html .gz

    That can fix Apache, sometimes. No idea how to do that with LiteSpeed.

  4. Miejsca
    Member
    Posted 5 years ago #

    It turns out Litespeed does gzip them anyway, with WP SUPER CACHE gz disabled.

Topic Closed

This topic has been closed to new replies.

About this Topic