WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Installation problem (9 posts)

  1. Milan Petrovic
    Member
    Posted 5 years ago #

    I tryed to set and use WP-Super-Cache on my localhost development blog, but I managed to activate plugin on plugin panel, and when I tried to oped plugin settings page, I got nothing. Output by server stops after this:

    <div class="wrap"><h2>WP Super Cache Manager</h2>

    After that nothing is rendered, and I can't activate plugin. I tried all things from FAQ for the plugin, nothing works.

    My localhost is on Apache from WampServer package on Windows XP. Am I doing something wrong?

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Anything in your php error log?

  3. Milan Petrovic
    Member
    Posted 5 years ago #

    Nothing, all is clean. No apache log errors, no php. Also, this is my development enviroment, so PHP errors will be displayed and logged.

  4. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Weird. There's an option in the php.ini to display startup errors. I find when that's activated a few more things show up.
    Also, check wp-content/wp-cache-config.php - any errors there?

  5. Milan Petrovic
    Member
    Posted 5 years ago #

    File looks ok, but it's not even loaded during the page initialization, I checked using debugger.

    I wanted to test and adjust my GD STar Rating plugin and the dynamic content generated by ratings to work with cache, and I will try over the weekend to figure out what the problem can be. I would like to test things on my development setup, before moving all that to production blogs for real life testing. Hopefully we can find the solution for this problem.

    Regards,
    Milan

  6. Kieslar
    Member
    Posted 5 years ago #

    I too tried to setup WP-Super-Cache on my localhost blog. I'm using Apache in XAMPP on Windows Vista. The plugin activation page cuts off at the exact same spot, and all logs are clean. I've noticed this problem for almost three months, but am only now getting around to trying to fix it. Did you ever find a solution to this problem?

  7. Donncha O Caoimh
    Member
    Posted 5 years ago #

    I can't debug this because I don't have a Windows machine to test it on. Sorry.

  8. Murmatron 2
    Member
    Posted 5 years ago #

    wp_cache_check_link() in wp-cache.php fails silently on Windows at line 960 due to
    @readlink($wp_cache_link)

    php readlink() doesn't exist on Windows

  9. buch0090
    Member
    Posted 5 years ago #

    I had similar issue on localhost/XP setup....Did you have advanced-cache.php and wp-cache-config.php in wp-content folder? Does wp-config.php have the 'wp-cache' enabled? Once I manually put those files there, and enabled wp-cache, the settings page came up.

Topic Closed

This topic has been closed to new replies.

About this Topic