WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Index page is cached but posts are not? (9 posts)

  1. utf-8
    Member
    Posted 5 years ago #

    I have installed WP Super Cache 0.8.6 but "cache" is not working for blog posts. If i check index file source there is

    <!-- Dynamic Page Served (once) in X.XXX seconds -->
    <!-- Cached page generated by WP-Super-Cache on X -->

    but if i check some post there is not "WP Super Cache" commment added to footer so wp-cache is not working for the posts?

    What did i do wrong? Please help me because i'm using too much servers resources and hosting provider will soon disable my account :(

  2. utf-8
    Member
    Posted 5 years ago #

    Do i have to add some code to "Accepted files" to cache posts?

    In Rejected URIs i have

    wp-.*.php
    index.php

    In Accepted files i have

    wp-comments-popup.php
    wp-links-opml.php
    wp-locations.php

    Do i have to change anything?

  3. What did i do wrong?

    Provide a link and we'll be able to see what you are talking about.

  4. utf-8
    Member
    Posted 5 years ago #

    Sorry but for some reason i cannot provide a link. I try to explain more exactly. If you don't know where is the problem i'll try to explain once again.

    If i open my-blog.com (index page) and look in the source of the code at the botom of the page (after </html> tag ) there is

    <!-- Dynamic Page Served (once) in 0.200 seconds -->
    <!-- Cached page generated by WP-Super-Cache on 2009-01-07 07:25:55 -->

    PICTURE: http://img394.imageshack.us/my.php?image=indexpageoo4.jpg

    But if i look at the source of some blog post (www.my-blog.com/some-blog-post/) there is nothing after tag </html>

    PICTURE: http://img243.imageshack.us/my.php?image=postpagemm0.jpg

    My WP Super Cache settings

    http://img508.imageshack.us/my.php?image=wpcachesettingshk1.jpg

  5. utf-8
    Member
    Posted 5 years ago #

    My blog post look like this:

    http://my-blog.org/index.php/name-of-blog-post/1724

    Does anyone know where is the problem?

  6. Sorry, but that's not helpful at all and does not shed any light on your situation.

    I respect that you don't want to reveal that link, but without actually seeing the output then I doubt you'll directly find a solution here.

    The only advice I can give you is

    1. Use TWO seperate browsers for testing. For example: use Firefox to log in change settings. At the same time use Opera, Safari, or even Internet Explorer to access the blog WITHOUT SIGNING IN. This way that second browser will get the output that regular viewers see.

    Check the HTML source from that second not logged in browser.

    2. Make sure you have fancy permalinks turned on. If you are using the default permalinks of ?p=123 then I don't think it will work. Edit: I see that you are using fancy links.

    3. Switch to the default theme. Make sure that the default theme is not modified. Check with that second not logged in browser: does that show the correct WP-Super-Cache output in the HTML source? If it does, your theme may somehow be at fault.

    4. Turn off all your plugins except WP-Super-Cache. I do mean ALL of them. Does that resolve the problem? If it does, turn them on one at a time until you find the culprit.

    Good luck.

  7. baal666
    Member
    Posted 5 years ago #

    I have a very alike problem specifically with Opera. Firefox and IE work well and cache is working, but not only is cache not working with Opera it also crashes. Opera does not use the cache; it reloads the page each time. Then, after switching back to FF and testing it again, I find that Opera simply closed itself.. actually no error, no crash, it simply closed itself... Weird.

    Any idea?

    Thanks.

    http://lelectronlibre.net

  8. baal666
    Member
    Posted 5 years ago #

    Here is what I have in the first window:

    wp-.*.php
    */2007/*
    */2008/*
    */2009/*
    *single.php*

    and I still get cached pages for 2009/03/etc.

    What is wrong?

    p.s. WP-Super-cache does save two index.html files: one in my default folder, and another one in a '/+/' folder... What exactly is that '+'?

    Thanks!

  9. baal666
    Member
    Posted 5 years ago #

    Well, whatever, my site probably isn't popular enough for that plugin anyway. Deactivated

Topic Closed

This topic has been closed to new replies.

About this Topic