WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
I get old recent Posts in sidebar.. Preload time is cause?? (6 posts)

  1. mobile-geeks
    Member
    Posted 3 years ago #

    I just noticed that when I view an old post, say published few hours ago, the recent posts list in the sidebar don't show the latest posts. It seems that when the page gets cached, the WP Super Cache also caches the recent posts list in the sidebar. I don't know it is the normal function of WP super cache but it is really bad for my blog's visitor because when they land on an old post, they might think that this blog has not been updated from last 2-3 days.

    When I view the posts while logged in, I see the most recent post list because I have ticked on "Don’t cache pages for known users. (Logged in users and those that comment)".

    My blog address is Mobile-Geeks
    Here is how I am using wp super cache:
    ticked: ON WP Cache and Super Cache enabled

    ticked: Don’t cache pages for known users. (Logged in users and those that comment)

    ticked: Cache rebuild. Serve a supercache file to anonymous users while a new file is being generated. Recommended for very busy websites with lots of comments. Makes "directly cached pages" and "Lockdown mode" obsolete.

    ticked: Mobile device support.

    ticked: Only refresh current page when comments made.

    selected: Preload mode (garbage collection only on half-on cache files. Recommended.) And the time set in the preload refresh is 2880 minutes.

    Super cache compression enabled.

    Expiry time 3600

    Now please advise me how to use this plugin so that it shows the most recent posts in sidebar?? or any code modification??

    I really love this plugin as it has saved my blog many times.
    Thanks

  2. qdinar
    Member
    Posted 3 years ago #

    i think checking "Clear all cache files when a post or page is published. (This may significantly slow down saving of posts.)" will help you.

    other way is to make expiry time or preload refresh time smaller, but while i have tried to set expire time to low value, like 30 seconds, it has not worked as i thought it should.
    i am afraid that if you set preload refresh time to value like 5 minutes, it will rebuild all cache every 5 minutes.

    other way is to find a plugin, that loads recent posts with javascript.

  3. mobile-geeks
    Member
    Posted 3 years ago #

    The first thing I want to clarify is that I have disabled compression because, I am sure, it is already enabled on my VPS.

    Secondly I was reading the FAQ of WP Super Cache plugin and found this interesting piece of information that if you want to keep certain parts dynamic, use the codes mentioned there. Now my question is that the first method will work in my case??

    Please help me in this area. I believe you are a big fan of wP super cache, so can you give it a try???

    @qdinar

    Thanks a lot.

  4. qdinar
    Member
    Posted 3 years ago #

    if your vps do not gzip output that is already gzipped, you better enable gzipping if you use ON mode, because it caches also gzipped files, while vps probably every time creates gzipped files.

    in that FAQ it is written about "half on" mode, i think. i think only in half on mode making some part dynamic is possible.

  5. mobile-geeks
    Member
    Posted 3 years ago #


  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    mobile-geeks - the plugin can't keep WordPress widgets dynamic unfortunately but it can keep code you add to your theme dynamic if you use the "mfunc" tag. You should also look at the "late init" feature too. It's in the readme or config file AFAIR.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic