WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
How to stop caching of one single page? (4 posts)

  1. Joe Siegler
    Member
    Posted 2 years ago #

    There's one page that's being prevented from working right with super cache, and that's a merchandise page. The links the page generates when forwarding on to Paypal aren't working right.

    I looked through the config, and found the area on how to stop things from being cached, but I'm obviously not doing it right, because it's still being cached (checked the source code at the bottom of the page).

    How can I stop this one page from being cached? Tkx.

    http://www.billward.com/merchandise

    Joe

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    You could also define the constant "DONOTCACHEPAGE" in that page's source code somewhere. That will stop the plugin caching the page.

  3. Joe Siegler
    Member
    Posted 2 years ago #

    Forgot about this. Is there anything somewhere that would tell me how to define that constant for a single page?

    I googled around, and what I found was inconclusive. Tkx.

  4. James Revillini
    Member
    Posted 2 years ago #

    Add the URL that you don't want cached to the list of URLs that shouldn't be cached in WP Supercache's advanced settings tab. By default it's got

    wp-.*\.php
    index\.php

    I think you can just add /merchandise to the list.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic