WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
How to disable super-cache on a per page basis? (4 posts)

  1. travellers
    Member
    Posted 3 years ago #

    I use the AWPCP plugin and need to ensure that super-cache recognises when a new advert is placed. Currently all adverts that were made after I enabled super-cache are not displaying on the advert 'home' page because I'm being served a cached version of it. Then I have another problem - this plugin comes with a widget which shows the latest 5 adverts, and of course these are not changing either when new adverts are added. Unfortunately the widget displays in the sidebar on almost every page so I can't really just turn off caching for those pages or there isn't much point in caching at all - I need a way of super-cache recognising when a new advert is placed and recaching the adverts home page and instances of the widget. How would I go about doing that?

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Check the FAQ - there's an entry about keeping part of your page dynamic but you'll need to modify how the plugin works.

  3. travellers
    Member
    Posted 3 years ago #

    I read the FAQ before posting here - there was a distinct whooshing noise overhead...

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    LOL, well then you'll need to contact the author of AWPCP (never used it so I can't help you there) to add support for Supercache. He basically needs to rotate the ads using Javascript just like Google Adsense does. Fairly easy to do in fact.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic