WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] How can I stop it from caching wp-cron.php? (6 posts)

  1. Derek Herman
    Member
    Posted 5 years ago #

    I am for one reason or another having to manually set a crontab in my Media Temple (dv) server pointing to wp-cron.php to get it to actually run my daily cron jobs and is an issue for another discussion.

    What I'm really wondering is if there is a way to stop wp-super-cache from even ever looking or trying to check if it's a page it should be caching? I added it to the do not cache pages but I still receive an hourly email from my cron job with the results saying

    <!-- Page not cached by WP Super Cache. No closing HTML tag. Check your theme. -->

    The cron job runs and tasks are updated hourly like they should be but my inbox is filling up fast with this unnecessary email.

    Is there a .htaccess rule or something I can add to stop this? I know the issue is with wp-super-cache, and not because of the text in the email, I checked it by turning of the plugin and testing the cron and there wasn't an email sent out, so it's obviously some setting somewhere that I can change or fix in the plugin to stop it.

    Help please!

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Derek Herman
    Member
    Posted 5 years ago #

    Anyone have any ideas?

  3. Donncha O Caoimh
    Member
    Posted 5 years ago #

    The crontab shouldn't be cached ever. It does a POST, not a GET and those requests aren't cached. Don't call wp-cron.php directly either.

    The default reject rules should stop any file starting with "wp-" being cached.

  4. Derek Herman
    Member
    Posted 5 years ago #

    How should I add wp-cron.php to my cron jobs then if I shouldn't call it directly?

  5. Donncha O Caoimh
    Member
    Posted 5 years ago #

    Under "Accepted Filenames & Rejected URIs" there's a textarea, by default it should be:
    wp-.*\.php
    index\.php

    That will stop it caching. WordPress calls the wp-cron.php periodically. No need to load it in your browser.

  6. Derek Herman
    Member
    Posted 5 years ago #

    I'm not loading it in my browser, and wp is not calling it periodically because cron jobs are left for months without being updated. I just finally got cron to run by going into plesk and manually running wp-cron.php with the use of a crontab. The issue is that the following is being emailed to me stating that indeed super cache is trying to cache the file:

    <!-- Page not cached by WP Super Cache. No closing HTML tag. Check your theme. -->

    If I turn off super cache the email is not sent. Either way the cron job is ran successfully but when cache is enabled I get an error email. I just want to know if there is a way to fix this.

Topic Closed

This topic has been closed to new replies.

About this Topic