WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] homepage.com no longer redirects to www.homepage.com after super-cache upgr (13 posts)

  1. thethinktank
    Member
    Posted 1 year ago #

    Hello!
    On August 3rd, I upgraded to the most recent version of WP Super Cache. Since then, the non-www domain no longer redirects to the http://www.domain. It shows an old version of my site from August 3rd.

    I noticed someone else had this problem, and read this forum thread:
    http://wordpress.org/support/topic/plugin-wp-super-cache-after-upgrade-caching-non-www-homepage

    My problem is that there is not an .htaccess file at .com/.htaccess on my server.

    Please advise!! I'm lost, and the many visitors that go to domain.com instead of http://www.domain.com are not seeing my recent content.

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. Marventus
    Member
    Posted 1 year ago #

    Hi.
    I believe that is a well known and standing issue with this plugin. If you Google "wp super cache redirection issues" you will see what I mean.
    Since I don't use this plugin I can't tell you whether or not there is a solution for this. I do know that you absolutely must have an .htaccess file in order for any cache plugin to work correctly.
    If you don't have one on your root folder (make sure you enable hidden file view), you can easily create one by creating an empty "htaccess.txt" file, uploading it to your server and renaming it to ".htaccess".
    If you still can't make it to work, W3 Total Cache works very well too and does not generate redirection problems AFAIK .
    Cheers!

  3. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    I'm not sure why the non-www domain sometimes generates a cached version because the plugin only caches whatever was requested. Normally WordPress redirects and Supercache does not try to cache the redirect, it'll cache the final (www.) request.

    As Marventus says, adding a .htaccess rule to redirect will fix the problem permanently.

  4. thethinktank
    Member
    Posted 1 year ago #

    Actually, I think I found a plugin incompatibility. I also run WP-DBManager, which I believe is the reason my htaccess file isn't located in the domain directory. I believe this plugin moves the htaccess file into the plugin's own directory. I'll look into this and see if I can resolve it, but it may be a reason for the lack of a redirect to http://www.mydomain.

  5. thethinktank
    Member
    Posted 1 year ago #

    Excuse my ignorance, I didn't know that a site could have multiple htaccess files so long as they're in different directories. I added a basic htaccess file to the domain directory and the problem has been solved. Feel free to mark this as closed.

    Donncha, Marventus, thanks for your time, I'm grateful!

  6. Marventus
    Member
    Posted 1 year ago #

    No problem. Glad you were able to figure this out.
    The thread can be marked as resolved by either you or Donncha, since he's one of the plugin devs.
    Cheers!

  7. thethinktank
    Member
    Posted 1 year ago #

    Got it, marking resolved now. Thanks again!

  8. thethinktank
    Member
    Posted 1 year ago #

    Actually, now all of my non http://www.mydomain.com urls are 404-ing, and the .htaccess file I added to my domain directory has disappeared. I'm screwed...

  9. Donncha O Caoimh
    Member
    Plugin Author

    Posted 1 year ago #

    Login to the backend of your blog and visit the permalinks settings page. The .htaccess file can be remade there.

  10. thethinktank
    Member
    Posted 1 year ago #

    This has been one problem after another. I was able to resolve the 404 issue, and I thought I had fixed the domain.com to http://www.domain.com redirect... and now none of my new content is showing up on my site. If I go direct to the new URLs, the content is there. But it is not listed on my homepage, which suggests that the new homepage (domain.com or http://www.domain.com) is itself a cache.

    It couldn't come at a worse time, as a new sponsorship started today and it includes a new article that is not showing on my site.

    Donncha, can I hire you to troubleshoot? Otherwise, if I remove WP Super Cache and try a new caching plugin, should that resolve this? I'm at a loss here.

  11. Marventus
    Member
    Posted 1 year ago #

    Did you try emptying all your caches to make sure WPSC is serving the latest version of your site?
    In my experience, all cache strategies (such as a plugin) require a little bit of testing and adjusting to make them work 100%, but if you don't have the time to do so, perhaps you should disable the plugin for now, unless your site receives a lot of visitors or your servers are being maxed out (which you won't know until you try).
    Another great tool to optimize your site is CloudFlare, which is basically a CDN with great tools and features, and they even let you open free accounts. I don't know if WPSC is compatible with CF, but maybe Donncha could fill in this information for me.
    Cheers!

  12. thethinktank
    Member
    Posted 1 year ago #

    Sorry for being a noob about all of this-- I used the "delete cache" button and the home page now shows my newest content. Curious, though-- might this suggest that I will have to manually delete the cache with this button any time I have new content?

  13. Marventus
    Member
    Posted 1 year ago #

    I'm pretty sure that when you publish new content, the cache gets emptied automatically. However, if you make changes to your theme, then the answer would be "yes", you need to empty your cache.
    Perhaps Donncha could confirm here.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic