WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] Home (index.php) serves fast, all other pages not (7 posts)

  1. Aron1
    Member
    Posted 3 years ago #

    First: Thanks for the great work :)

    I installed wp-super-cache and (as far as I can tell) its working. I find the comment in the bottom of the pages, the cached pages are listed in the Cache Tester and I have no error (except the one, that mod_expires is not installed).

    Also I find, that the homepage (index.php) is served super fast (tested using Firebug, Page Speed and YSlow), ~140ms compared to up to 1 sec before.

    However, strangely for all subpages this speed boost does not apply. Actually there is not that big of a difference to before I installed wp-super-cache (~800ms). Even if the page barely has content.

    Does this sounds familiar? Or must this be something outside of wp-super-cache?

    Thanks

  2. Aron1
    Member
    Posted 3 years ago #

    Ok, checked the comment more accurate:

    <!-- Dynamic page generated in 0.603 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2010-09-24 19:30:17 -->
    <!-- Compression = gzip -->

    All pages (except the home) are newly generated on every hit.

    What can this be? A plugin? Or misconfiguration?

    Thanks

  3. Aron1
    Member
    Posted 3 years ago #

    Confirmed. With the option "List the newest cached pages on this page" I can see in the yellow box, that all subpages are newly cached, when I reload them.

    Again, for the home page, this does not apply. The homepage are cached correctly.

    Now I'm looking for differences home vs. posts. There is not one plugin, that is used in the posts but not on the home (There aren't much plugins installed anyway).

    Can I be the permalink? I'm using custom /%postname%/

    Thanks

  4. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    Can you try the development version on this page?

  5. Aron1
    Member
    Posted 3 years ago #

    Yup, that fixed it. Last thing: It seams that mod_expires is not installed on my server, can I still use mod_rewrite to serve cache files?

  6. Donncha O Caoimh
    Member
    Plugin Author

    Posted 3 years ago #

    You shouldn't as browsers will cache the pages of your site *too much* and may not see updates when they reload. On the other, most people probably won't notice anything as the only reason they'll reload is after they leave a comment. When they do that mod_rewrite doesn't serve the page.

    I'd say use PHP caching.

  7. Aron1
    Member
    Posted 3 years ago #

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic