WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Google Analytics Not Working with SuperCache (7 posts)

  1. gmcguire
    Member
    Posted 4 years ago #

    My Google Analytics for my blog isn't working with SuperCache. Is there a workaround to get the Analytics code to register hits on cached pages?

  2. Pinoy.ca
    Member
    Posted 4 years ago #

    Do you mean you see the GA javascript code in uncached pages and you don't see it in cached ones?

    * How did you add the GA javascript code? Using a WordPress GA Plugin (which one?) or by editing your footer.php?
    * Is your SuperCache on or half-on?

  3. gmcguire
    Member
    Posted 4 years ago #

    I mean that my GA went to zero hits/day after adding Supercache to my blog. The javascript is in the footer.php. Right now Supercach is all the way on.

  4. willard97
    Member
    Posted 4 years ago #

    Same thing happened to me. Right after installing Supercache my stats went to zero. GA is installed properly in the footer and GA is "receiving data", the data is just not appearing in my GA account.

  5. itwilleasy
    Member
    Posted 4 years ago #

    So am I. I use google analytics and getclicky. Before use wp super cache the visit each day in both are small: 200 per day. But now the getclicky is 200 Google anlytics is only 40.

    Who can help us. What much I do.

    * How did you add the GA javascript code? Using a WordPress GA Plugin (which one?) or by editing your footer.php?
    I editing footer.php?
    * Is your SuperCache on or half-on?
    I use WP Cache and Super Cache enabled
    (what is different between them)

  6. MarqueCreative
    Member
    Posted 4 years ago #

    I've noticed this also. I wonder if the plugin author is still active.

  7. Donncha is active and still writing this plugin :)

    I have Google analytics and adsense in my blog, added into the footer manually (no plugin) and wp-s-c and I've not seen any difference. In fact, I had it in when I had 3 times the normal pageviews and everything worked as expected.

    Can you provide your URLs? There may be some evidence in the page source that could help debug.

    Also, what other java related plugins are you using?

Topic Closed

This topic has been closed to new replies.

About this Topic