WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Garbage Collection (10 posts)

  1. france1972
    Member
    Posted 5 years ago #

    so, i have set my super cache to 250 sec as far as Expiry Time and Garbage Collection is concerned while i have set the deletion of expired files to one hour. after 5 hours i have around 300 expired files and apparently none has been deleted. i have to delete exprired files manually. it is normal or am i missing soemthing? thanks in advance! i am using the latest version of super cache and i am with wp 2.7

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. forefront
    Member
    Posted 5 years ago #

    I was about to post the same question. Expired files need to be removed manually.

    Using WP 2.7 and Super Cache 0.8.7

    Thanks.

  3. buch0090
    Member
    Posted 5 years ago #

    I've been grappling with this exact issue for over a month. Have to go in and manually delete the expired files, otherwise my site doesn't serve up super-cached pages....

    What platform are you on? Windows or Linux? And since I'm still very march in the dark on what the problem is...Did you do the symlink for advanced cache file and/or does the wp-content have the proper access? Do you get a warning on the super-cache settings page?

  4. forefront
    Member
    Posted 5 years ago #

    I am using a Dreamhost server and no matter what I do the files are not removed.

  5. chaz7979
    Member
    Posted 5 years ago #

    Ditto.

    Seems enough people are reporting this that there must be some common issue. The plug seems to work for me except for this one bug, it must be traceable to something being configured incorrectly???

  6. chaz7979
    Member
    Posted 5 years ago #

    I setup the email debugging and it says
    "Cache Expiry cron job failed. Probably mutex locked."

    Are you guys seeing the same thing? I am glad he put in the debug mode but I dont know what the message means!

  7. blogrelations
    Member
    Posted 5 years ago #

    Could this have something to do with daylight savings? WordPress general settings says

    Unfortunately, you have to manually update this for Daylight Savings Time. Lame, we know, but will be fixed in the future.

    Just wondering if this doesn't match garbage collection schedule, it might not happen

  8. Donncha O Caoimh
    Member
    Posted 5 years ago #

    blogrelations - No, DST would only have affected a cron job on the night things changed. If you have problems with clearing out expired files then disabling file locking will help.

  9. marhgil
    Member
    Posted 4 years ago #

    @donncha - i am still having this problem. I'm on Dreamhost PS. I have this on my access.log:

    - [14/Aug/2009:00:34:23 -0700] "POST /wp-cron.php?doing_wp_cron HTTP/1.0" 200 628 "-" "WordPress/2.8.4; http://www.macuha.com"

    That means wp-cron.php is accessible, there's no 404 error.

    But my expired super cache files are not deleted. I have to manually delete them. There's no problem with the WP-Cache garbage collection. Only on WP-Super-Cache.

    I tried disabling file locking as suggested, but I got the "blank screen of death" after making $use_flock = false.

    Please help.

  10. marhgil
    Member
    Posted 4 years ago #

    My problem was already solved. No need to reply. The solution: I just unchecked the "Coarse File Locking" option.

Topic Closed

This topic has been closed to new replies.

About this Topic