WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WP Super Cache] Front page no longer served by super-cache (9 posts)

  1. seriocomic
    Member
    Posted 5 years ago #

    After both wp-cache and super-cache are activated for a short while, a request for the root/homepage results in an archive page being served. This can only be resolved by either clearing the cache or setting the plugin to 'half'.

    I have been upgrading both WordPress and WP-Super-Cache for some time now.

    Anyone else having the same issue? Any solution?

  2. alanpace
    Member
    Posted 5 years ago #

    No solution, but you're not the only one. Someone else reported this problem, and I'm having almost the same issue. In my case the correct home page of the site is a static page, not a blog page, but WP-Cache eventually starts erroneously serving the front page of the blog on the home page. The workaround is the same as you described: either clearing the cache or setting the plugin to "half". I thought I'd solved the problem by turning off file locking. With debugging notifications activated turning off file locking was the only way I could eliminate debug messages, and that seemed to have also corrected this problem. However, after a few days the "wrong home page" issue returned.

  3. marcrue
    Member
    Posted 5 years ago #

    Same issue here, but:

    We do have 9 identical blogs, (only changes the css) and its happening only on two of them, instead of showing the homa page (wich must be a static page from our blog) its serving an archive page from the first category (wich has no posts) resulting a 404 in front page.

    Every time super cache refreshes the home page it turns in that 404.

    our blogs are all WordPress 2.7

  4. westondeboer
    Member
    Posted 5 years ago #

    I am having this same issue. After maybe a couple of hours or so the front page goes to 404. The rest of the site is working fine, just the front page. We are pulling a custom category for the front page, but besides that everything else is pretty cut and dry.

    WordPress 2.7.1
    http://obeygiant.com

  5. blakekr
    Member
    Posted 5 years ago #

    I was having a similar problem with a recent version of supercache and a WP version 2.6.1. I had to downgrade for now until this problem gets resolved. Had a random archive page get served up in place of my home page (ONLY for those without a cookie) which caused SEO havoc. EDIT: I forgot to mention that my home page is a static html, unconnected to wordpress.

  6. rajupp
    Member
    Posted 5 years ago #

    I am exactly having the same issue. Everytime super cache refreshes, my homepage starts returning 404. This is damn ridiculous. I hope donncha or someone else cares to reply to this thread with a solution. A release every week doesn't help with these sort of bugs.

  7. Donncha O Caoimh
    Member
    Posted 5 years ago #

    rajupp - snide remarks don't encourage help from support people either. Please be polite.

    I don't know why that happens. Please list your plugins, your theme (and url to theme) and what's on your front page (posts or a static page).

    When you get the 404, is it a WordPress 404 page or is it a generic Apache 404? Do you have any plugin that does special things to catch 404 requests? Does the 404 request get cached in the wp-content/cache/supercache/hostname/index.html(.gz)?
    Is the 404 recorded in a cached file in wp-content/cache/ ?

    Does your theme or any of the plugins you have use query_posts()? That overwrites the 404 error flag and messes up the caching. There's already a fix in the plugin for that but there might other ways of overwriting the 404 status. The 404 page shouldn't be cached at all.

  8. tvds
    Member
    Posted 4 years ago #

    Same problem here.....

    It's a wordpress 404

  9. Donncha O Caoimh
    Member
    Posted 4 years ago #

    tvds - can you debug it? I can't replicate this problem on my server so I can't fix it.

Topic Closed

This topic has been closed to new replies.

About this Topic